summaryrefslogtreecommitdiff
path: root/dev-ml/zarith/zarith-1.4.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ml/zarith/zarith-1.4.1.ebuild')
-rw-r--r--dev-ml/zarith/zarith-1.4.1.ebuild46
1 files changed, 0 insertions, 46 deletions
diff --git a/dev-ml/zarith/zarith-1.4.1.ebuild b/dev-ml/zarith/zarith-1.4.1.ebuild
deleted file mode 100644
index 8825fc311e45..000000000000
--- a/dev-ml/zarith/zarith-1.4.1.ebuild
+++ /dev/null
@@ -1,46 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-inherit findlib eutils toolchain-funcs
-
-DESCRIPTION="Arithmetic and logic operations over arbitrary-precision integers"
-HOMEPAGE="https://forge.ocamlcore.org/projects/zarith/"
-SRC_URI="https://forge.ocamlcore.org/frs/download.php/1574/${P}.tgz"
-
-LICENSE="LGPL-2.1-with-linking-exception"
-SLOT="0/${PV}"
-KEYWORDS="~amd64 ~ppc ~x86"
-IUSE="doc mpir +ocamlopt"
-
-RDEPEND="
- >=dev-lang/ocaml-4:=[ocamlopt?]
- !mpir? ( dev-libs/gmp:0= )
- mpir? ( sci-libs/mpir )"
-
-DEPEND="${RDEPEND} dev-lang/perl"
-
-src_configure() {
- tc-export CC
- ./configure -host "${CHOST}" \
- -ocamllibdir "/usr/$(get_libdir)" \
- -installdir "${ED}/usr/$(get_libdir)/ocaml" \
- $(usex mpir "-mpir" "-gmp") || die
-}
-
-src_compile() {
- emake HASOCAMLOPT=$(usex ocamlopt yes no) HASDYNLINK=$(usex ocamlopt yes no) all
- use doc && emake doc
-}
-
-src_test() {
- emake HASOCAMLOPT=$(usex ocamlopt yes no) HASDYNLINK=$(usex ocamlopt yes no) tests
-}
-
-src_install() {
- findlib_src_preinst
- emake HASOCAMLOPT=$(usex ocamlopt yes no) HASDYNLINK=$(usex ocamlopt yes no) install
- dodoc Changes README
- use doc && dohtml html/*
-}