summaryrefslogtreecommitdiff
path: root/dev-perl/Authen-Radius/Authen-Radius-0.260.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-perl/Authen-Radius/Authen-Radius-0.260.0.ebuild')
-rw-r--r--dev-perl/Authen-Radius/Authen-Radius-0.260.0.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/dev-perl/Authen-Radius/Authen-Radius-0.260.0.ebuild b/dev-perl/Authen-Radius/Authen-Radius-0.260.0.ebuild
new file mode 100644
index 000000000000..f95b495f9fd6
--- /dev/null
+++ b/dev-perl/Authen-Radius/Authen-Radius-0.260.0.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DIST_AUTHOR=PORTAONE
+DIST_VERSION=0.26
+inherit perl-module
+
+DESCRIPTION="Communicate with a Radius server from Perl"
+
+LICENSE="Artistic-2"
+SLOT="0"
+KEYWORDS="amd64 ~hppa ~sparc x86"
+IUSE="test"
+
+RDEPEND="
+ >=virtual/perl-Data-Dumper-1.0.0
+ >=dev-perl/Data-HexDump-0.20.0
+ >=virtual/perl-Digest-MD5-2.200.0
+ >=virtual/perl-IO-1.120.0
+ >=dev-perl/Net-IP-1.260.0
+"
+DEPEND="${RDEPEND}
+ >=virtual/perl-ExtUtils-MakeMaker-6.640.0
+ test? (
+ dev-perl/Test-NoWarnings
+ virtual/perl-Test-Simple
+ )
+"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.26-cisco-dictionary.patch
+ "${FILESDIR}"/${PN}-0.26-no-install-db.patch
+)
+
+src_configure() {
+ export OPTIMIZE="$CFLAGS"
+ perl-module_src_configure
+}
+
+src_install() {
+ perl-module_src_install
+
+ # Really want to install these radius dictionaries?
+ insinto /etc/raddb
+ doins raddb/dictionary*
+}