summaryrefslogtreecommitdiff
path: root/dev-perl/B-Hooks-EndOfScope/B-Hooks-EndOfScope-0.280.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-perl/B-Hooks-EndOfScope/B-Hooks-EndOfScope-0.280.0.ebuild')
-rw-r--r--dev-perl/B-Hooks-EndOfScope/B-Hooks-EndOfScope-0.280.0.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-perl/B-Hooks-EndOfScope/B-Hooks-EndOfScope-0.280.0.ebuild b/dev-perl/B-Hooks-EndOfScope/B-Hooks-EndOfScope-0.280.0.ebuild
new file mode 100644
index 000000000000..eaa919f1e505
--- /dev/null
+++ b/dev-perl/B-Hooks-EndOfScope/B-Hooks-EndOfScope-0.280.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DIST_AUTHOR=ETHER
+DIST_VERSION=0.28
+inherit perl-module
+
+DESCRIPTION="Execute code after a scope finished compilation"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos"
+
+RDEPEND="
+ >=dev-perl/Module-Implementation-0.50.0
+ virtual/perl-Scalar-List-Utils
+ >=dev-perl/Sub-Exporter-Progressive-0.1.6
+ >=dev-perl/Variable-Magic-0.480.0
+"
+BDEPEND="
+ ${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ virtual/perl-Text-ParseWords
+ test? (
+ >=virtual/perl-CPAN-Meta-2.120.900
+ >=dev-perl/Devel-Hide-0.0.700
+ virtual/perl-File-Spec
+ >=virtual/perl-Test-Simple-0.880.0
+ )
+"