summaryrefslogtreecommitdiff
path: root/dev-perl/CDB_File/CDB_File-0.990.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-perl/CDB_File/CDB_File-0.990.0.ebuild')
-rw-r--r--dev-perl/CDB_File/CDB_File-0.990.0.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-perl/CDB_File/CDB_File-0.990.0.ebuild b/dev-perl/CDB_File/CDB_File-0.990.0.ebuild
new file mode 100644
index 000000000000..98e092b2f202
--- /dev/null
+++ b/dev-perl/CDB_File/CDB_File-0.990.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DIST_AUTHOR=TODDR
+DIST_VERSION=0.99
+DIST_EXAMPLES=("examples/*")
+inherit perl-module
+
+DESCRIPTION="Tie to CDB (Bernstein's constant DB) files"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND=""
+DEPEND="virtual/perl-ExtUtils-MakeMaker
+ test? ( virtual/perl-Test-Simple )
+"
+
+src_prepare() {
+ mkdir "${S}/examples"
+ einfo "Moving bun-x.pl to examples/"
+ cp "${S}/bun-x.pl" "${S}/examples/"
+ perl_rm_files bun-x.pl
+ perl-module_src_prepare
+}