summaryrefslogtreecommitdiff
path: root/dev-perl/CGI-Compile
diff options
context:
space:
mode:
Diffstat (limited to 'dev-perl/CGI-Compile')
-rw-r--r--dev-perl/CGI-Compile/CGI-Compile-0.210.0.ebuild26
-rw-r--r--dev-perl/CGI-Compile/CGI-Compile-0.220.0.ebuild26
-rw-r--r--dev-perl/CGI-Compile/Manifest7
-rw-r--r--dev-perl/CGI-Compile/files/CGI-Compile-0.210.0-perl-526.patch137
-rw-r--r--dev-perl/CGI-Compile/metadata.xml12
5 files changed, 208 insertions, 0 deletions
diff --git a/dev-perl/CGI-Compile/CGI-Compile-0.210.0.ebuild b/dev-perl/CGI-Compile/CGI-Compile-0.210.0.ebuild
new file mode 100644
index 000000000000..f26f71037d9b
--- /dev/null
+++ b/dev-perl/CGI-Compile/CGI-Compile-0.210.0.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DIST_AUTHOR=MIYAGAWA
+DIST_VERSION=0.21
+inherit perl-module
+
+DESCRIPTION="Compile .cgi scripts to a code reference like ModPerl::Registry"
+SLOT="0"
+KEYWORDS="~alpha amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="test"
+
+RDEPEND="
+ dev-perl/File-pushd
+"
+DEPEND="${RDEPEND}
+ >=dev-perl/Module-Build-Tiny-0.34.0
+ test? (
+ dev-perl/Test-NoWarnings
+ dev-perl/Test-Requires
+ virtual/perl-Test-Simple
+ )
+"
+PATCHES=("${FILESDIR}/${P}-perl-526.patch")
diff --git a/dev-perl/CGI-Compile/CGI-Compile-0.220.0.ebuild b/dev-perl/CGI-Compile/CGI-Compile-0.220.0.ebuild
new file mode 100644
index 000000000000..3eaa6040e600
--- /dev/null
+++ b/dev-perl/CGI-Compile/CGI-Compile-0.220.0.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DIST_AUTHOR=MIYAGAWA
+DIST_VERSION=0.22
+inherit perl-module
+
+DESCRIPTION="Compile .cgi scripts to a code reference like ModPerl::Registry"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="test"
+
+RDEPEND="
+ dev-perl/File-pushd
+"
+DEPEND="${RDEPEND}
+ >=dev-perl/Module-Build-Tiny-0.34.0
+ test? (
+ dev-perl/Test-NoWarnings
+ dev-perl/Test-Requires
+ virtual/perl-Test-Simple
+ )
+"
+PATCHES=("${FILESDIR}/${PN}-0.210.0-perl-526.patch")
diff --git a/dev-perl/CGI-Compile/Manifest b/dev-perl/CGI-Compile/Manifest
new file mode 100644
index 000000000000..74ff88f55c00
--- /dev/null
+++ b/dev-perl/CGI-Compile/Manifest
@@ -0,0 +1,7 @@
+AUX CGI-Compile-0.210.0-perl-526.patch 2937 SHA256 35af17d17d3b95522d4d65faafee84d7d78cb438e76922e534f600d7e65d8642 SHA512 e9d4589ef1a0deeeb71127173953ce78382d8775e1d8da2f6761707f9eb28ca90e988bdbc4623def2991e94e9c958ee1257d3e8e94abff29ff7203d26dec6f5a WHIRLPOOL 84211176601240807374974921ba2f96921e675a3f02ebdbc27887e129e616480846d7b99b453ef7bc6f8001fb75008d6748a787649df723701c77dad4a930ba
+DIST CGI-Compile-0.21.tar.gz 20910 SHA256 ed2c12e12ad3bde9d0a73344851692982c0c05d0650fa0c03df66f63c0977838 SHA512 0b26fbe4a38645df3aeae03647292125210147321ed9552bbd871824915fabaafdac8601667bddfb73038b7f096d19e1ba7a00acaa5dc28865c1f97247ad5e64 WHIRLPOOL 74b51dd793eee9a584519dfc9eadb6434445f371d6458f06a0fe811383cd593c5a055aa02c1cf261e729b6ce913dfea961b1ff8793cd325536056e25ad13cdcd
+DIST CGI-Compile-0.22.tar.gz 21160 SHA256 f5094e9c6b793e3168cb621f1f661f8e1abb4f141761e0b79a0859bd5e5bccaf SHA512 58be714bd25975fbb66e4c83c197fa3c17219327859d965011706fda96d5c2f208831e52368c0b4b8ef6b0f462b9c8ea216d94d7ef30e904e21b818b134cc5b7 WHIRLPOOL 6b799318c95f50bda37c78b7579d0b2d699ae1f7a9b965db04bde56c7bf15d6dbcb2d924bf1772ff66595399643a1428225e8670295229174c204b8efe909202
+EBUILD CGI-Compile-0.210.0.ebuild 556 SHA256 ff7182a908b72e1757c8e317f69caede145815255d2e107cb5fcfe992373e608 SHA512 d847098192b30efacdfc77cdf35f01c352abf9acf8a6fbba6b4df9f99cdcfd299cfc09239648a0a8f53623e3225fede5b2808e56986f4f4cf0e29497886b11a8 WHIRLPOOL 0d82b8668d4f07d558d1a86bafd67d38958e53c197ad9702d04bdd7e949f047cfd97ee96d3a8c4bb99326d6b4e5120c26c868bd2af4b12465200c40b4f43efd9
+EBUILD CGI-Compile-0.220.0.ebuild 566 SHA256 e4bf76f0421bc8e858a1d6797dec8e523a15c37389c8c87f64bc1c851e60b0f1 SHA512 4fcc112f835f46f4e9ee8adc70641120404d52c1fe262aa5de7385890d71e6d68466a57e530b5a5a06ec65c074e6f848c806de2efa8bcda5a4ed33d56c62cbd4 WHIRLPOOL 41dd9a9b0b6a26e1a954317cc702c95827d5163cd727636946de2896ea2f014a890b002dd64cad0e2551ca33b714237ce19534cae755da8f1d592b4209a67288
+MISC ChangeLog 379 SHA256 56c3b44737b6ab2c592d3799efe138bc2194a44fe4e2ff154aa38ad50cf7bc4a SHA512 bdafcdefbceb618e47097ea98b1a383c2ba7ab1285e1a0b7182ee6f9297479622ce0c686250a9948810f0b98a09828a492bc637a09e7d1c185f4420416e6e2d8 WHIRLPOOL a4e3150b659023bc9717f10bd8f9ae5e59d23ca2140e0f8c1a2a793c2f963eea5fcd8c353fba597de49a382f694a8bf52853abe70f307b0c34be6a829e23d247
+MISC metadata.xml 394 SHA256 700509bf79bc125abec90430e4176c0d88589566cffa81910caa40076f7c7c18 SHA512 7d0c50b0b8c75c5ddce5b77400b88223a3481a1615071c6e32d9dd491b6c8d7a85abfc8309e16407c1886a12a5a4dc312cf8c2ec7c0c07e10c26707a2dd710f3 WHIRLPOOL 23642755830cb20e5e4889b1d868cef0ed63b49f5103c04110f1846901d85123bbe280ccf292897d653e75ef9b6cbda2d2e567abc11646af27b72d13f96542c9
diff --git a/dev-perl/CGI-Compile/files/CGI-Compile-0.210.0-perl-526.patch b/dev-perl/CGI-Compile/files/CGI-Compile-0.210.0-perl-526.patch
new file mode 100644
index 000000000000..74945fb94886
--- /dev/null
+++ b/dev-perl/CGI-Compile/files/CGI-Compile-0.210.0-perl-526.patch
@@ -0,0 +1,137 @@
+From dc9437c949a4f44ca8b36bbf974d6a49337c67b4 Mon Sep 17 00:00:00 2001
+From: Kent Fredric <kentnl@gentoo.org>
+Date: Sun, 1 Oct 2017 04:10:33 +1300
+Subject: Fix tests failure on Perl 5.26+ with PERL_USE_UNSAFE_INC=0
+
+Bug: https://github.com/miyagawa/CGI-Compile/issues/21
+Bug: https://bugs.gentoo.org/614352
+---
+ t/Capture.pm | 3 ++-
+ t/coderef_args.t | 3 ++-
+ t/compile.t | 3 ++-
+ t/data_end.t | 4 +++-
+ t/exit.t | 2 +-
+ t/local-SIG.t | 3 ++-
+ t/source.t | 3 ++-
+ t/source_filter.t | 3 ++-
+ t/warnings.t | 3 ++-
+ 9 files changed, 18 insertions(+), 9 deletions(-)
+
+diff --git a/t/Capture.pm b/t/Capture.pm
+index 476f80d..2331b33 100644
+--- a/t/Capture.pm
++++ b/t/Capture.pm
+@@ -1,4 +1,5 @@
+-package t::Capture;
++package # Hide from PAUSE
++ Capture;
+ use base qw(Exporter);
+ our @EXPORT = qw(capture_out);
+
+diff --git a/t/coderef_args.t b/t/coderef_args.t
+index 8d9c1b4..89720dd 100644
+--- a/t/coderef_args.t
++++ b/t/coderef_args.t
+@@ -1,5 +1,6 @@
+ use Test::More;
+-use t::Capture;
++use lib 't';
++use Capture;
+ use CGI::Compile;
+
+ my $sub = CGI::Compile->compile("t/args.cgi");
+diff --git a/t/compile.t b/t/compile.t
+index db42283..f302f9b 100644
+--- a/t/compile.t
++++ b/t/compile.t
+@@ -1,6 +1,7 @@
+ use Test::More;
+ use Test::Requires qw(CGI);
+-use t::Capture;
++use lib 't';
++use Capture;
+ use CGI::Compile;
+ #no warnings 'signal'; # for MSWin32
+
+diff --git a/t/data_end.t b/t/data_end.t
+index af468f7..175641f 100644
+--- a/t/data_end.t
++++ b/t/data_end.t
+@@ -1,6 +1,8 @@
+ use Test::More;
+ use CGI::Compile;
+-use t::Capture;
++
++use lib 't';
++use Capture;
+
+ {
+ my $sub = CGI::Compile->compile("t/data.cgi");
+diff --git a/t/exit.t b/t/exit.t
+index b98b28a..2167b1c 100644
+--- a/t/exit.t
++++ b/t/exit.t
+@@ -1,8 +1,8 @@
+ use strict;
+ use Test::More tests => 2;
+ use CGI::Compile;
+-use t::Capture;
+ use lib "t";
++use Capture;
+ use Exit;
+
+ my $sub = CGI::Compile->compile("t/exit.cgi");
+diff --git a/t/local-SIG.t b/t/local-SIG.t
+index b781c05..68f733e 100644
+--- a/t/local-SIG.t
++++ b/t/local-SIG.t
+@@ -1,6 +1,7 @@
+ #!perl
+
+-use t::Capture;
++use lib 't';
++use Capture;
+ use CGI::Compile;
+ use POSIX qw(:signal_h);
+
+diff --git a/t/source.t b/t/source.t
+index e212244..b101632 100644
+--- a/t/source.t
++++ b/t/source.t
+@@ -1,6 +1,7 @@
+ use Test::More;
+ use CGI::Compile;
+-use t::Capture;
++use lib 't';
++use Capture;
+
+ {
+ my $str =<<EOL;
+diff --git a/t/source_filter.t b/t/source_filter.t
+index 8b84e0c..51b11b2 100644
+--- a/t/source_filter.t
++++ b/t/source_filter.t
+@@ -1,6 +1,7 @@
+ use Test::More;
+ use Test::Requires qw(Switch);
+-use t::Capture;
++use lib 't';
++use Capture;
+ use CGI::Compile;
+
+ my $sub = eval {
+diff --git a/t/warnings.t b/t/warnings.t
+index 5962aae..0d044cb 100644
+--- a/t/warnings.t
++++ b/t/warnings.t
+@@ -1,5 +1,6 @@
+ use Test::More;
+-use t::Capture;
++use lib 't';
++use Capture;
+ use CGI::Compile;
+
+ my $sub = CGI::Compile->compile("t/warnings.cgi");
+--
+2.14.1
+
diff --git a/dev-perl/CGI-Compile/metadata.xml b/dev-perl/CGI-Compile/metadata.xml
new file mode 100644
index 000000000000..c6f78b9fa272
--- /dev/null
+++ b/dev-perl/CGI-Compile/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>perl@gentoo.org</email>
+ <name>Gentoo Perl Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="cpan">CGI-Compile</remote-id>
+ <remote-id type="cpan-module">CGI::Compile</remote-id>
+ </upstream>
+</pkgmetadata>