summaryrefslogtreecommitdiff
path: root/dev-perl/Carp-Assert-More/Carp-Assert-More-2.0.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-perl/Carp-Assert-More/Carp-Assert-More-2.0.1.ebuild')
-rw-r--r--dev-perl/Carp-Assert-More/Carp-Assert-More-2.0.1.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-perl/Carp-Assert-More/Carp-Assert-More-2.0.1.ebuild b/dev-perl/Carp-Assert-More/Carp-Assert-More-2.0.1.ebuild
new file mode 100644
index 000000000000..62fe69dcc9cc
--- /dev/null
+++ b/dev-perl/Carp-Assert-More/Carp-Assert-More-2.0.1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DIST_AUTHOR=PETDANCE
+inherit perl-module
+
+DESCRIPTION="Convenience assertions for common situations"
+LICENSE="Artistic-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~ppc ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos"
+
+RDEPEND="
+ virtual/perl-Carp
+ virtual/perl-Scalar-List-Utils
+"
+BDEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ test? (
+ dev-perl/Test-Exception
+ >=virtual/perl-Test-Simple-0.180.0
+ )
+"
+
+PERL_RM_FILES=(
+ "t/pod-coverage.t"
+ "t/pod.t"
+)