summaryrefslogtreecommitdiff
path: root/dev-perl/Crypt-OpenSSL-Random/Crypt-OpenSSL-Random-0.110.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-perl/Crypt-OpenSSL-Random/Crypt-OpenSSL-Random-0.110.0.ebuild')
-rw-r--r--dev-perl/Crypt-OpenSSL-Random/Crypt-OpenSSL-Random-0.110.0.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-perl/Crypt-OpenSSL-Random/Crypt-OpenSSL-Random-0.110.0.ebuild b/dev-perl/Crypt-OpenSSL-Random/Crypt-OpenSSL-Random-0.110.0.ebuild
new file mode 100644
index 000000000000..825deae22d91
--- /dev/null
+++ b/dev-perl/Crypt-OpenSSL-Random/Crypt-OpenSSL-Random-0.110.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DIST_AUTHOR=RURBAN
+DIST_VERSION=0.11
+inherit perl-module
+
+DESCRIPTION="OpenSSL/LibreSSL pseudo-random number generator access"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
+IUSE="libressl"
+
+RDEPEND="
+ !libressl? ( dev-libs/openssl:0 )
+ libressl? ( dev-libs/libressl )
+"
+DEPEND="${RDEPEND}"
+
+export OPTIMIZE="${CFLAGS}"
+mydoc="ToDo"
+
+src_test() {
+ perl_rm_files t/z_{kwalitee,manifest,meta,perl-minimum_version}.t \
+ t/z_pod-coverage.t t/z_pod.t
+ perl-module_src_test
+}