summaryrefslogtreecommitdiff
path: root/dev-perl/Crypt-SMIME/Crypt-SMIME-0.300.0-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-perl/Crypt-SMIME/Crypt-SMIME-0.300.0-r1.ebuild')
-rw-r--r--dev-perl/Crypt-SMIME/Crypt-SMIME-0.300.0-r1.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/dev-perl/Crypt-SMIME/Crypt-SMIME-0.300.0-r1.ebuild b/dev-perl/Crypt-SMIME/Crypt-SMIME-0.300.0-r1.ebuild
new file mode 100644
index 000000000000..4950faf02a50
--- /dev/null
+++ b/dev-perl/Crypt-SMIME/Crypt-SMIME-0.300.0-r1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DIST_AUTHOR=MIKAGE
+DIST_VERSION=0.30
+inherit perl-module
+
+DESCRIPTION="S/MIME message signing, verification, encryption and decryption"
+
+SLOT="0"
+KEYWORDS="amd64 ~x86"
+IUSE="minimal"
+
+RDEPEND="
+ >=dev-libs/openssl-0.9.9:=
+ virtual/perl-XSLoader
+"
+DEPEND=">=dev-libs/openssl-0.9.9:="
+BDEPEND="
+ ${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ dev-perl/ExtUtils-PkgConfig
+ dev-perl/ExtUtils-CChecker
+ test? (
+ dev-perl/Test-Exception
+ virtual/perl-Test-Simple
+ !minimal? (
+ >=dev-perl/Test-Taint-1.60.0
+ >=dev-perl/Taint-Util-0.80.0
+ )
+ )
+"
+
+PERL_RM_FILES=(
+ t/boilerplate.t
+ t/manifest.t
+ t/pod-coverage.t
+ t/pod.t
+)