summaryrefslogtreecommitdiff
path: root/dev-perl/EV/EV-4.340.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-perl/EV/EV-4.340.0.ebuild')
-rw-r--r--dev-perl/EV/EV-4.340.0.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-perl/EV/EV-4.340.0.ebuild b/dev-perl/EV/EV-4.340.0.ebuild
new file mode 100644
index 000000000000..3a1cb46b8450
--- /dev/null
+++ b/dev-perl/EV/EV-4.340.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DIST_AUTHOR=MLEHMANN
+DIST_VERSION=4.34
+inherit flag-o-matic perl-module
+
+DESCRIPTION="Perl interface to libev, a high performance full-featured event loop"
+
+LICENSE=" || ( Artistic GPL-1+ ) || ( BSD-2 GPL-2+ )"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~riscv ~x86"
+
+RDEPEND="
+ dev-perl/common-sense
+"
+BDEPEND="
+ ${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ dev-perl/Canary-Stability
+"
+
+src_compile() {
+ # See bug #855869 and its large number of dupes in bundled libev copies.
+ filter-lto
+ append-flags -fno-strict-aliasing
+
+ perl-module_src_compile
+}