summaryrefslogtreecommitdiff
path: root/dev-perl/Festival-Client-Async/Festival-Client-Async-0.30.300-r3.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-perl/Festival-Client-Async/Festival-Client-Async-0.30.300-r3.ebuild')
-rw-r--r--dev-perl/Festival-Client-Async/Festival-Client-Async-0.30.300-r3.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-perl/Festival-Client-Async/Festival-Client-Async-0.30.300-r3.ebuild b/dev-perl/Festival-Client-Async/Festival-Client-Async-0.30.300-r3.ebuild
new file mode 100644
index 000000000000..7a0c21a49511
--- /dev/null
+++ b/dev-perl/Festival-Client-Async/Festival-Client-Async-0.30.300-r3.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DIST_AUTHOR=DJHD
+DIST_VERSION=0.0303
+DIST_WIKI="tests"
+inherit perl-module
+
+DESCRIPTION="Non-blocking interface to a Festival server"
+
+SLOT="0"
+KEYWORDS="amd64 ~ia64 sparc x86"
+
+src_test() {
+ local MODULES=(
+ "Festival::Client::Async ${DIST_VERSION}"
+ )
+ local failed=()
+ for dep in "${MODULES[@]}"; do
+ ebegin "Compile testing ${dep}"
+ perl -Mblib="${S}" -M"${dep} ()" -e1
+ eend $? || failed+=( "$dep" )
+ done
+ if [[ ${failed[@]} ]]; then
+ echo
+ eerror "One or more modules failed compile:";
+ for dep in "${failed[@]}"; do
+ eerror " ${dep}"
+ done
+ die "Failing due to module compilation errors";
+ fi
+ perl-module_src_test
+}