summaryrefslogtreecommitdiff
path: root/dev-perl/MCE/MCE-1.889.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-perl/MCE/MCE-1.889.0.ebuild')
-rw-r--r--dev-perl/MCE/MCE-1.889.0.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-perl/MCE/MCE-1.889.0.ebuild b/dev-perl/MCE/MCE-1.889.0.ebuild
new file mode 100644
index 000000000000..d5e25739eee3
--- /dev/null
+++ b/dev-perl/MCE/MCE-1.889.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DIST_AUTHOR=MARIOROY
+DIST_VERSION=1.889
+inherit perl-module
+
+DESCRIPTION="Many-Core Engine providing parallel processing capabilities"
+
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="+sereal"
+
+RDEPEND="
+ virtual/perl-Carp
+ virtual/perl-File-Path
+ virtual/perl-Getopt-Long
+ virtual/perl-IO
+ virtual/perl-Scalar-List-Utils
+ virtual/perl-Socket
+ >=virtual/perl-Storable-2.40.0
+ virtual/perl-Time-HiRes
+ sereal? (
+ >=dev-perl/Sereal-Encoder-3.15.0
+ >=dev-perl/Sereal-Decoder-3.15.0
+ )
+"
+BDEPEND="
+ ${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ test? ( >=virtual/perl-Test-Simple-0.880.0 )
+"