summaryrefslogtreecommitdiff
path: root/dev-perl/Module-Runtime/Module-Runtime-0.16.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-perl/Module-Runtime/Module-Runtime-0.16.0.ebuild')
-rw-r--r--dev-perl/Module-Runtime/Module-Runtime-0.16.0.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-perl/Module-Runtime/Module-Runtime-0.16.0.ebuild b/dev-perl/Module-Runtime/Module-Runtime-0.16.0.ebuild
new file mode 100644
index 000000000000..3dd23d7a18f7
--- /dev/null
+++ b/dev-perl/Module-Runtime/Module-Runtime-0.16.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DIST_AUTHOR=ZEFRAM
+DIST_VERSION=0.016
+inherit perl-module
+
+DESCRIPTION="Runtime module handling"
+
+SLOT="0"
+KEYWORDS="alpha amd64 arm ~arm64 hppa ia64 ~m68k ~mips ppc ppc64 ~s390 ~sh sparc x86 ~ppc-aix ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x86-solaris"
+IUSE="test"
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ dev-perl/Module-Build
+ test? (
+ virtual/perl-Test-Simple
+ )
+"
+
+src_test() {
+ perl_rm_files t/pod_cvg.t t/pod_syn.t
+ perl-module_src_test
+}