summaryrefslogtreecommitdiff
path: root/dev-perl/Net-SSH2/Net-SSH2-0.580.0-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-perl/Net-SSH2/Net-SSH2-0.580.0-r1.ebuild')
-rw-r--r--dev-perl/Net-SSH2/Net-SSH2-0.580.0-r1.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/dev-perl/Net-SSH2/Net-SSH2-0.580.0-r1.ebuild b/dev-perl/Net-SSH2/Net-SSH2-0.580.0-r1.ebuild
new file mode 100644
index 000000000000..f9768f58738f
--- /dev/null
+++ b/dev-perl/Net-SSH2/Net-SSH2-0.580.0-r1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DIST_AUTHOR=SALVA
+DIST_VERSION=0.58
+DIST_EXAMPLES=( "example/*" )
+inherit perl-module
+
+DESCRIPTION="Support for the SSH 2 protocol via libssh2"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="gcrypt libressl"
+
+RDEPEND="
+ sys-libs/zlib
+ net-libs/libssh2
+ !gcrypt? (
+ !libressl? ( dev-libs/openssl:0 )
+ libressl? ( dev-libs/libressl )
+ )
+ gcrypt? (
+ dev-libs/libgcrypt:0
+ )
+"
+DEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-Constant
+ >=virtual/perl-ExtUtils-MakeMaker-6.50
+"
+
+src_prepare() {
+ sed -i -e 's/use inc::Module::Install/use lib q[.]; use inc::Module::Install/' Makefile.PL ||
+ die "Can't patch Makefile.PL for 5.26 dot-in-inc"
+ perl-module_src_prepare
+}
+
+src_configure() {
+ use gcrypt && myconf=gcrypt
+ perl-module_src_configure
+}