summaryrefslogtreecommitdiff
path: root/dev-perl
diff options
context:
space:
mode:
Diffstat (limited to 'dev-perl')
-rw-r--r--dev-perl/Bio-SamTools/Bio-SamTools-1.430.0-r2.ebuild45
-rw-r--r--dev-perl/Bio-SamTools/Manifest4
-rw-r--r--dev-perl/Bio-SamTools/files/Bio-SamTools-1.430.0-legacy-r1.patch110
-rw-r--r--dev-perl/Bio-SamTools/metadata.xml32
-rw-r--r--dev-perl/Manifest.gzbin283062 -> 282897 bytes
5 files changed, 0 insertions, 191 deletions
diff --git a/dev-perl/Bio-SamTools/Bio-SamTools-1.430.0-r2.ebuild b/dev-perl/Bio-SamTools/Bio-SamTools-1.430.0-r2.ebuild
deleted file mode 100644
index e8109c9688f3..000000000000
--- a/dev-perl/Bio-SamTools/Bio-SamTools-1.430.0-r2.ebuild
+++ /dev/null
@@ -1,45 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-DIST_AUTHOR=LDS
-DIST_VERSION=1.43
-inherit perl-module toolchain-funcs
-
-DESCRIPTION="Read SAM/BAM database files"
-
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-
-RDEPEND="
- >=sci-biology/bioperl-1.6.9
- sci-biology/samtools:0.1-legacy=
-"
-DEPEND="
- dev-perl/Module-Build
- sci-biology/samtools:0.1-legacy=
-"
-BDEPEND="${RDEPEND}
- virtual/perl-ExtUtils-CBuilder
- >=dev-perl/Module-Build-0.420.0
-"
-
-PATCHES=(
- "${FILESDIR}"/${PN}-1.430.0-legacy-r1.patch
-)
-
-src_configure() {
- tc-export CC
- unset LD
- if [[ -n "${CCLD}" ]]; then
- export LD="${CCLD}"
- fi
- SAM_LIB="${EPREFIX}/usr/$(get_libdir)/libbam-0.1-legacy.so" \
- SAM_INCLUDE="${EPREFIX}/usr/include/bam-0.1-legacy" \
- perl-module_src_configure
-}
-
-src_compile() {
- ./Build --config optimize="${CFLAGS}" build || die
-}
diff --git a/dev-perl/Bio-SamTools/Manifest b/dev-perl/Bio-SamTools/Manifest
deleted file mode 100644
index 30c0fc7e858a..000000000000
--- a/dev-perl/Bio-SamTools/Manifest
+++ /dev/null
@@ -1,4 +0,0 @@
-AUX Bio-SamTools-1.430.0-legacy-r1.patch 2934 BLAKE2B 17e310aeac8d2548e168c125d498b623fb3ea6ac59da52c9dd7918c4a42a5fe6c3a11488fe67d833f265151330f339e6700bb323e5e6f355a445e58b96546246 SHA512 ac995f9a55e7cac70238f7945f56f91bbbafe207dc55b05115d519737c9a626fa57ccb265c78f028c1a03297bf5916dc60b7d51fe9988b30d27021b03717c750
-DIST Bio-SamTools-1.43.tar.gz 340833 BLAKE2B 2b488667b86ef1bedb7cf74dfdcb3abc0302d9f309c1fc3077682bb400c8307f3b7d8fb1a9015a26f9a17f9e9955845d160512aa3273c368b720fe51b4392458 SHA512 cd5bc6213c093f5105399c95278803afcc537bb3d191686cda0193b82fda2580749bf7533791899939a78963fcc0d6b36eabe9c309c9c6816a9849e3c892c41b
-EBUILD Bio-SamTools-1.430.0-r2.ebuild 866 BLAKE2B b61066da65835d034a1750a6517b7a585b8017685336ede2f58e1ba3b5d9d70f23aac87471a821876cbcbf60e5399f0a3f908830167ca6ad581b80f60df2c01c SHA512 cf72334c5c90921a22c36eb6ce918de9545638dbe581dcf0ffdb7fb789c5fc49dafd497c34b3cce400d899c47458e84ceb8487d1db8728c75e10a618b7429990
-MISC metadata.xml 1643 BLAKE2B 399d081acd642322e85b475778cd12254a2ad6e58fb3482c90e4bd7a3bb351ec62745a8cf8e259d016be76cd3ccb5468c25504dee1b5c0d647f1f3d564f71362 SHA512 04e6e085702322156f8c915de822fb535034e155fbf5bd23627c63c7af13874dbab05c9518d4413258c65550a839507f8f34dfd21ec600479445f59c1b8d72ec
diff --git a/dev-perl/Bio-SamTools/files/Bio-SamTools-1.430.0-legacy-r1.patch b/dev-perl/Bio-SamTools/files/Bio-SamTools-1.430.0-legacy-r1.patch
deleted file mode 100644
index ee9bde8fe3d0..000000000000
--- a/dev-perl/Bio-SamTools/files/Bio-SamTools-1.430.0-legacy-r1.patch
+++ /dev/null
@@ -1,110 +0,0 @@
-From 82942523b2db5143a9da0f9d2f8ec83a26c8d5b0 Mon Sep 17 00:00:00 2001
-From: Kent Fredric <kentfredric@gmail.com>
-Date: Sun, 10 Sep 2017 13:33:32 +1200
-Subject: Fix linking/compiling for bam-0.1-legacy
-
----
- Build.PL | 14 +++++++-------
- c_bin/bam2bedgraph.c | 2 +-
- c_bin/makefile | 6 +++---
- lib/Bio/DB/Sam.xs | 6 +++---
- 4 files changed, 14 insertions(+), 14 deletions(-)
-
-diff --git a/Build.PL b/Build.PL
-index 685815f..882f231 100644
---- a/Build.PL
-+++ b/Build.PL
-@@ -4,11 +4,10 @@ use strict;
- use Module::Build;
- use Module::Load::Conditional qw(can_load);
-
--my $HeaderFile = "bam.h";
--my $LibFile = "libbam.a";
--my $ReadLine;
--
--my ($sam_include,$sam_lib) = find_sam(); # may exit with error here
-+my ($sam_include,$sam_lib) = do {
-+ ($ENV{"SAM_INCLUDE"} || die "SAM_INCLUDE not set"),
-+ ($ENV{"SAM_LIB"} || die "SAM_LIB not set")
-+};
-
- my $class = Module::Build->subclass(code=><<EOF);
- sub process_c_bin_files {
-@@ -39,7 +38,7 @@ my $build = $class->new(
- dist_abstract => 'Perl interface to SamTools library for DNA sequencing',
- license => 'perl',
- include_dirs => [$sam_include],
-- extra_linker_flags => ["-L$sam_lib",'-lbam','-lpthread','-lz'],
-+ extra_linker_flags => ["-L$sam_lib",'-lbam-0.1-legacy','-lpthread','-lz'],
-
- extra_compiler_flags=>[
-
-@@ -67,7 +66,7 @@ $build->add_build_element('c_bin');
- $build->create_build_script;
-
- exit 0;
--
-+=for non-gentoo
- sub find_sam {
- my ($sam_include,$sam_lib);
-
-@@ -162,6 +161,7 @@ sub prompt {
- $ReadLine->addhistory($in) if $in =~ /\S/;
- return $in;
- }
-+=cut
-
- sub _samtools {
- $ENV{SAMTOOLS} ||
-diff --git a/c_bin/bam2bedgraph.c b/c_bin/bam2bedgraph.c
-index 298e9a8..91218fa 100644
---- a/c_bin/bam2bedgraph.c
-+++ b/c_bin/bam2bedgraph.c
-@@ -1,5 +1,5 @@
- #include <stdio.h>
--#include "sam.h"
-+#include "bam-0.1-legacy/sam.h"
-
- typedef struct {
- uint32_t ltid;
-diff --git a/c_bin/makefile b/c_bin/makefile
-index 9aef917..0abbb4c 100644
---- a/c_bin/makefile
-+++ b/c_bin/makefile
-@@ -1,5 +1,5 @@
--CC= gcc
--CFLAGS= -g -Wall -O2 -fPIC
-+CC?= gcc
-+CFLAGS?= -g -Wall -O2 -fPIC
- DFLAGS= -D_FILE_OFFSET_BITS=64 -D_LARGEFILE64_SOURCE -D_USE_KNETFILE -D_CURSES_LIB=1
- INCLUDES=
- LIBPATH=
-@@ -14,7 +14,7 @@ PROG= bam2bedgraph
- all:$(PROG)
-
- bam2bedgraph: bam2bedgraph.o
-- $(CC) $(CFLAGS) -o $@ $< $(LDFLAGS) $(LIBPATH) -lbam -lpthread -lm -lz
-+ $(CC) $(CFLAGS) -o $@ $< $(LDFLAGS) $(LIBPATH) -lbam-0.1-legacy -lpthread -lm -lz
-
- clean:
- rm -f *.o $(PROG)
-diff --git a/lib/Bio/DB/Sam.xs b/lib/Bio/DB/Sam.xs
-index 023f655..86410fb 100644
---- a/lib/Bio/DB/Sam.xs
-+++ b/lib/Bio/DB/Sam.xs
-@@ -25,9 +25,9 @@
-
- #include <unistd.h>
- #include <math.h>
--#include "bam.h"
--#include "khash.h"
--#include "faidx.h"
-+#include "bam-0.1-legacy/bam.h"
-+#include "bam-0.1-legacy/khash.h"
-+#include "bam-0.1-legacy/faidx.h"
-
- /* stolen from bam_aux.c */
- #define MAX_REGION 1<<29
---
-2.26.2
-
diff --git a/dev-perl/Bio-SamTools/metadata.xml b/dev-perl/Bio-SamTools/metadata.xml
deleted file mode 100644
index 9baf5e76ea79..000000000000
--- a/dev-perl/Bio-SamTools/metadata.xml
+++ /dev/null
@@ -1,32 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="project">
- <email>sci@gentoo.org</email>
- <name>Gentoo Science Project</name>
- </maintainer>
- <maintainer type="project">
- <email>perl@gentoo.org</email>
- <name>Gentoo Perl Project</name>
- </maintainer>
- <upstream>
- <remote-id type="cpan">Bio-SamTools</remote-id>
- <remote-id type="cpan-module">Bio::DB::Bam</remote-id>
- <remote-id type="cpan-module">Bio::DB::Bam::AlignWrapper</remote-id>
- <remote-id type="cpan-module">Bio::DB::Bam::Alignment</remote-id>
- <remote-id type="cpan-module">Bio::DB::Bam::FetchIterator</remote-id>
- <remote-id type="cpan-module">Bio::DB::Bam::Pileup</remote-id>
- <remote-id type="cpan-module">Bio::DB::Bam::PileupWrapper</remote-id>
- <remote-id type="cpan-module">Bio::DB::Bam::Query</remote-id>
- <remote-id type="cpan-module">Bio::DB::Bam::ReadIterator</remote-id>
- <remote-id type="cpan-module">Bio::DB::Bam::SplitAlignmentPart</remote-id>
- <remote-id type="cpan-module">Bio::DB::Bam::Target</remote-id>
- <remote-id type="cpan-module">Bio::DB::Sam</remote-id>
- <remote-id type="cpan-module">Bio::DB::Sam::Constants</remote-id>
- <remote-id type="cpan-module">Bio::DB::Sam::Fai</remote-id>
- <remote-id type="cpan-module">Bio::DB::Sam::SamToGBrowse</remote-id>
- <remote-id type="cpan-module">Bio::DB::Sam::Segment</remote-id>
- <remote-id type="cpan-module">Bio::DB::Sam::Segment::Iterator</remote-id>
- <remote-id type="cpan-module">Bio::SeqFeature::Coverage</remote-id>
- </upstream>
-</pkgmetadata>
diff --git a/dev-perl/Manifest.gz b/dev-perl/Manifest.gz
index 8a08ab8acb81..d51a507c2bc8 100644
--- a/dev-perl/Manifest.gz
+++ b/dev-perl/Manifest.gz
Binary files differ