summaryrefslogtreecommitdiff
path: root/dev-php/PEAR-File_Find/PEAR-File_Find-1.3.3.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-php/PEAR-File_Find/PEAR-File_Find-1.3.3.ebuild')
-rw-r--r--dev-php/PEAR-File_Find/PEAR-File_Find-1.3.3.ebuild46
1 files changed, 0 insertions, 46 deletions
diff --git a/dev-php/PEAR-File_Find/PEAR-File_Find-1.3.3.ebuild b/dev-php/PEAR-File_Find/PEAR-File_Find-1.3.3.ebuild
deleted file mode 100644
index aabe1137ca4b..000000000000
--- a/dev-php/PEAR-File_Find/PEAR-File_Find-1.3.3.ebuild
+++ /dev/null
@@ -1,46 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-MY_PN="${PN/PEAR-/}"
-MY_P="${MY_PN}-${PV}"
-
-DESCRIPTION="A class that facillitates the search of filesystems"
-HOMEPAGE="https://pear.php.net/package/File_Find"
-SRC_URI="http://download.pear.php.net/package/${MY_P}.tgz"
-LICENSE="PHP-3.01"
-SLOT="0"
-KEYWORDS="amd64 ~hppa ppc ppc64 sparc x86"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-# Really only needs PEAR-Exception at runtime.
-RDEPEND="dev-lang/php:*
- dev-php/PEAR-PEAR"
-DEPEND="test? ( dev-php/PEAR-PEAR )"
-
-S="${WORKDIR}/${MY_P}"
-
-src_prepare() {
- eapply_user
-
- # Without this sed, the test suite will try (and fail) to mess
- # around in /tmp.
- sed -i "s~'/tmp'~'${T}'~" tests/setup.php \
- || die 'failed to fix temporary directory in tests/setup.php'
-}
-
-src_install() {
- insinto /usr/share/php
- doins -r File
-}
-
-src_test() {
- # Requires the "pear" executable from dev-php/PEAR-PEAR.
- pear run-tests tests || die
-
- # The command succeeds regardless of whether or not the test suite
- # passed, but this file is only written when there was a failure.
- [[ -f run-tests.log ]] && die "test suite failed"
-}