summaryrefslogtreecommitdiff
path: root/dev-php/PEAR-Services_JSON/PEAR-Services_JSON-1.0.3-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-php/PEAR-Services_JSON/PEAR-Services_JSON-1.0.3-r1.ebuild')
-rw-r--r--dev-php/PEAR-Services_JSON/PEAR-Services_JSON-1.0.3-r1.ebuild19
1 files changed, 19 insertions, 0 deletions
diff --git a/dev-php/PEAR-Services_JSON/PEAR-Services_JSON-1.0.3-r1.ebuild b/dev-php/PEAR-Services_JSON/PEAR-Services_JSON-1.0.3-r1.ebuild
new file mode 100644
index 000000000000..9e52d443b4b0
--- /dev/null
+++ b/dev-php/PEAR-Services_JSON/PEAR-Services_JSON-1.0.3-r1.ebuild
@@ -0,0 +1,19 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit php-pear-r2
+
+IUSE=""
+DESCRIPTION="PHP implementaion of json_encode/decode"
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+PATCHES=( "${FILESDIR}/JSON-1.0.3-upstream-typo.patch" "${FILESDIR}/JSON-1.0.3-constructor.patch" )
+
+src_install() {
+ php-pear-r2_src_install
+ insinto /usr/share/php/Services
+ doins JSON.php
+}