summaryrefslogtreecommitdiff
path: root/dev-php/PEAR-VersionControl_SVN/PEAR-VersionControl_SVN-0.5.2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-php/PEAR-VersionControl_SVN/PEAR-VersionControl_SVN-0.5.2.ebuild')
-rw-r--r--dev-php/PEAR-VersionControl_SVN/PEAR-VersionControl_SVN-0.5.2.ebuild19
1 files changed, 19 insertions, 0 deletions
diff --git a/dev-php/PEAR-VersionControl_SVN/PEAR-VersionControl_SVN-0.5.2.ebuild b/dev-php/PEAR-VersionControl_SVN/PEAR-VersionControl_SVN-0.5.2.ebuild
new file mode 100644
index 000000000000..b5fa0ac56497
--- /dev/null
+++ b/dev-php/PEAR-VersionControl_SVN/PEAR-VersionControl_SVN-0.5.2.ebuild
@@ -0,0 +1,19 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit php-pear-r1
+
+DESCRIPTION="Simple OO wrapper interface for the Subversion command-line client"
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="alpha amd64 hppa ia64 ppc ppc64 sparc x86"
+IUSE=""
+RDEPEND=""
+
+src_prepare() {
+ einfo "Patching SVN.php and SVN/Command.php to use proper paths by default"
+ sed -i -e 's:/usr/local:/usr:g' VersionControl/SVN.php || die "sed failed"
+ sed -i -e 's:/usr/local:/usr:g' VersionControl/SVN/Command.php || die "sed failed"
+}