summaryrefslogtreecommitdiff
path: root/dev-php/pecl-stomp/pecl-stomp-2.0.2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-php/pecl-stomp/pecl-stomp-2.0.2.ebuild')
-rw-r--r--dev-php/pecl-stomp/pecl-stomp-2.0.2.ebuild17
1 files changed, 9 insertions, 8 deletions
diff --git a/dev-php/pecl-stomp/pecl-stomp-2.0.2.ebuild b/dev-php/pecl-stomp/pecl-stomp-2.0.2.ebuild
index a4649795c926..99522e6709c5 100644
--- a/dev-php/pecl-stomp/pecl-stomp-2.0.2.ebuild
+++ b/dev-php/pecl-stomp/pecl-stomp-2.0.2.ebuild
@@ -1,15 +1,15 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
-USE_PHP="php5-6 php7-0 php7-1 php7-2 php7-3"
+USE_PHP="php5-6 php7-1 php7-2 php7-3"
PHP_EXT_NAME="stomp"
DOCS=( CREDITS doc/classes.php doc/functions.php )
inherit php-ext-pecl-r3
-USE_PHP="php7-0 php7-1 php7-2 php7-3"
+USE_PHP="php7-1 php7-2 php7-3"
KEYWORDS="~amd64 ~x86"
@@ -19,7 +19,6 @@ SLOT="7"
IUSE="examples ssl test"
DEPEND="${DEPEND}
- php_targets_php7-0? ( dev-lang/php:7.0[ssl?] )
php_targets_php7-1? ( dev-lang/php:7.1[ssl?] )
php_targets_php7-2? ( dev-lang/php:7.2[ssl?] )
php_targets_php7-3? ( dev-lang/php:7.3[ssl?] )
@@ -28,8 +27,10 @@ DEPEND="${DEPEND}
RDEPEND="${DEPEND}
php_targets_php5-6? ( dev-php/pecl-stomp:0 )"
+DEPEND="virtual/pkgconfig ${DEPEND}"
+
src_prepare() {
- if use php_targets_php7-0 || use php_targets_php7-1 || use php_targets_php7-2 || use php_targets_php7-3 ; then
+ if use php_targets_php7-1 || use php_targets_php7-2 || use php_targets_php7-3 ; then
php-ext-source-r3_src_prepare
else
default
@@ -37,17 +38,17 @@ src_prepare() {
}
src_configure() {
- if use php_targets_php7-0 || use php_targets_php7-1 || use php_targets_php7_2 || use php_targets_php7-3 ; then
+ if use php_targets_php7-1 || use php_targets_php7-2 || use php_targets_php7-3 ; then
local PHP_EXT_ECONF_ARGS=(
--enable-stomp
- --with-openssl-dir=$(usex ssl "${EPREFIX}/usr")
+ --with-openssl-dir=$(usex ssl yes no)
)
php-ext-source-r3_src_configure
fi
}
src_install() {
- if use php_targets_php7-0 || use php_targets_php7-1 || use php_targets_php7_2 || use php_targets_php7-3 ; then
+ if use php_targets_php7-1 || use php_targets_php7-2 || use php_targets_php7-3 ; then
php-ext-pecl-r3_src_install
fi
}