summaryrefslogtreecommitdiff
path: root/dev-python/Babel/Babel-2.8.0-r2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/Babel/Babel-2.8.0-r2.ebuild')
-rw-r--r--dev-python/Babel/Babel-2.8.0-r2.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-python/Babel/Babel-2.8.0-r2.ebuild b/dev-python/Babel/Babel-2.8.0-r2.ebuild
new file mode 100644
index 000000000000..6c6523761a40
--- /dev/null
+++ b/dev-python/Babel/Babel-2.8.0-r2.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( pypy3 python3_{6..9} )
+PYTHON_REQ_USE="threads(+)"
+DISTUTILS_USE_SETUPTOOLS=rdepend
+
+inherit distutils-r1
+
+DESCRIPTION="Collection of tools for internationalizing Python applications"
+HOMEPAGE="https://babel.pocoo.org/ https://pypi.org/project/Babel/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~m68k ~mips ppc ppc64 ~riscv s390 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris"
+
+RDEPEND="dev-python/pytz[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+DEPEND="${DEPEND}
+ test? ( dev-python/freezegun[${PYTHON_USEDEP}] )"
+
+distutils_enable_sphinx docs
+distutils_enable_tests pytest
+
+PATCHES=(
+ "${FILESDIR}"/${P}-py39.patch
+)
+
+src_test() {
+ local -x TZ=UTC
+ distutils-r1_src_test
+}