summaryrefslogtreecommitdiff
path: root/dev-python/Nuitka
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/Nuitka')
-rw-r--r--dev-python/Nuitka/Manifest4
-rw-r--r--dev-python/Nuitka/Nuitka-2.4.8-r1.ebuild (renamed from dev-python/Nuitka/Nuitka-2.4.7.ebuild)2
-rw-r--r--dev-python/Nuitka/Nuitka-2.4.8.ebuild52
3 files changed, 3 insertions, 55 deletions
diff --git a/dev-python/Nuitka/Manifest b/dev-python/Nuitka/Manifest
index ad0ea8e6be5c..d560c676aa69 100644
--- a/dev-python/Nuitka/Manifest
+++ b/dev-python/Nuitka/Manifest
@@ -1,5 +1,3 @@
-DIST Nuitka-2.4.7.tar.gz 3719215 BLAKE2B afe2aa119db21d36377f41cbd8a20bdfb732ca5dc111ebc4156c9f4e12f3828d8d17ceb5423e49829fa2554a0e8416822af7148efb1efa14b49628f03b9791fc SHA512 08ab175180ed21ae0341cc88c9644351137054476fba00ee0c857c3c30f1a1da6c240fc9af873a9bc92faee657af11bd4108613a9c721ff27c6d73a603021ad0
DIST Nuitka-2.4.8.tar.gz 3720021 BLAKE2B f3e89107e25baf0490e8dccba9c5e3e167fbdba395d21c8f9666a4f3e094c72fc295a7c57536deabaeb04dc0cb6682dcdf675f1305d5974e49e989c643aa6769 SHA512 da36c84e295f313c76d955498c8d4b46a57c162366dc9374188ae4bf236ad27df8a034c7942f089e1f4e196f44de27ab9d8dedeae991d9c29a51e86018eadb6f
-EBUILD Nuitka-2.4.7.ebuild 1110 BLAKE2B b092bfe4db9bebe649cd0b5c84a9b608d8c99511d4d73c94952b215fe09981e60e033f3e47ba5eaa7332914d6b47629f1584e00b95818d9c2e956ff1675ff410 SHA512 ce843edbc7c36c9a2603e39808862188d33ed93d4cafb5c5ace041da50282c312709cbf0806bb18a828344f241d69b8d5e331b9c24d78f6fa313769283161ebd
-EBUILD Nuitka-2.4.8.ebuild 1110 BLAKE2B b092bfe4db9bebe649cd0b5c84a9b608d8c99511d4d73c94952b215fe09981e60e033f3e47ba5eaa7332914d6b47629f1584e00b95818d9c2e956ff1675ff410 SHA512 ce843edbc7c36c9a2603e39808862188d33ed93d4cafb5c5ace041da50282c312709cbf0806bb18a828344f241d69b8d5e331b9c24d78f6fa313769283161ebd
+EBUILD Nuitka-2.4.8-r1.ebuild 1207 BLAKE2B 7ee2a45162555ba9564abd987b30e62cd295ce587a74b09907df2fa01f3546e432bbfbab4aec6b481844dec15a9e18808845db7e68e266ff3cc8db27fb7b52bf SHA512 2042b723261e7a2804dafe5b116d4e5b4e63f7a84f16786e600335f422d616bf23a46152a40ded3d63034a13241749694c654d260bd9789bf2b86bf9808e44ce
MISC metadata.xml 943 BLAKE2B d7ab883773e7480dcfb4b79932a3874e2274669169a24a54aa622a2a0ac079e0296da4bd196d166cb11fcff785985da0b10d0fae351032914ccf312c9bb9833c SHA512 625d8760b8e849c6e014856f584cb42f50bb5ebb1fa648cb704a5a1baf175e7d2ce9f43f6f724d11c81a68e364b6ac1c38459540b58f2ccd6a675902af5b1cc9
diff --git a/dev-python/Nuitka/Nuitka-2.4.7.ebuild b/dev-python/Nuitka/Nuitka-2.4.8-r1.ebuild
index 274aff9ae3b5..98d5f5591788 100644
--- a/dev-python/Nuitka/Nuitka-2.4.7.ebuild
+++ b/dev-python/Nuitka/Nuitka-2.4.8-r1.ebuild
@@ -24,6 +24,8 @@ RESTRICT="!test? ( test )"
RDEPEND="
dev-build/scons[${PYTHON_USEDEP}]
+ >=dev-python/ordered-set-4.1.0[${PYTHON_USEDEP}]
+ >=dev-python/zstandard-0.15[${PYTHON_USEDEP}]
"
BDEPEND="
${RDEPEND}
diff --git a/dev-python/Nuitka/Nuitka-2.4.8.ebuild b/dev-python/Nuitka/Nuitka-2.4.8.ebuild
deleted file mode 100644
index 274aff9ae3b5..000000000000
--- a/dev-python/Nuitka/Nuitka-2.4.8.ebuild
+++ /dev/null
@@ -1,52 +0,0 @@
-# Copyright 1999-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYPI_NO_NORMALIZE=1
-PYTHON_COMPAT=( python3_{10..12} )
-
-inherit distutils-r1 flag-o-matic optfeature pypi
-
-DESCRIPTION="Python to native compiler"
-HOMEPAGE="
- https://nuitka.net/
- https://github.com/Nuitka/Nuitka/
- https://pypi.org/project/Nuitka/
-"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~amd64 ~loong ~x86"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
- dev-build/scons[${PYTHON_USEDEP}]
-"
-BDEPEND="
- ${RDEPEND}
- test? ( dev-util/ccache )
-"
-
-distutils-r1_src_prepare() {
- # remove vendored version of SCons that is Python2 only
- # this should be removed when upstream removes support for Python2
- rm -vR "nuitka/build/inline_copy/lib/scons-2.3.2/SCons" || die
- eapply_user
-}
-
-python_install() {
- distutils-r1_python_install
- doman doc/nuitka.1 doc/nuitka-run.1
-}
-
-python_test() {
- append-ldflags -Wl,--no-warn-search-mismatch
- ./tests/basics/run_all.py search || die
-}
-
-pkg_postinst() {
- optfeature "support for stand-alone executables" dev-util/patchelf
-}