summaryrefslogtreecommitdiff
path: root/dev-python/PyPDF2/PyPDF2-1.26.0-r2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/PyPDF2/PyPDF2-1.26.0-r2.ebuild')
-rw-r--r--dev-python/PyPDF2/PyPDF2-1.26.0-r2.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-python/PyPDF2/PyPDF2-1.26.0-r2.ebuild b/dev-python/PyPDF2/PyPDF2-1.26.0-r2.ebuild
new file mode 100644
index 000000000000..f58c46912f0d
--- /dev/null
+++ b/dev-python/PyPDF2/PyPDF2-1.26.0-r2.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python library to work with PDF files"
+HOMEPAGE="https://pypi.org/project/PyPDF2/ https://github.com/mstamy2/PyPDF2"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~x86"
+IUSE="examples"
+
+PATCHES=( "${FILESDIR}/${P}-py3-tests.patch" )
+
+python_test() {
+ "${EPYTHON}" -m unittest Tests.tests || die "Tests failed under ${EPYTHON}"
+}
+
+python_install_all() {
+ if use examples; then
+ docinto examples
+ dodoc -r Sample_Code/.
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+ distutils-r1_python_install_all
+}