summaryrefslogtreecommitdiff
path: root/dev-python/PyQt5-sip/PyQt5-sip-12.13.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/PyQt5-sip/PyQt5-sip-12.13.0.ebuild')
-rw-r--r--dev-python/PyQt5-sip/PyQt5-sip-12.13.0.ebuild18
1 files changed, 18 insertions, 0 deletions
diff --git a/dev-python/PyQt5-sip/PyQt5-sip-12.13.0.ebuild b/dev-python/PyQt5-sip/PyQt5-sip-12.13.0.ebuild
new file mode 100644
index 000000000000..f7aee3db4722
--- /dev/null
+++ b/dev-python/PyQt5-sip/PyQt5-sip-12.13.0.ebuild
@@ -0,0 +1,18 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_EXT=1
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYPI_PN=${PN/-/_}
+PYTHON_COMPAT=( python3_{10..12} )
+inherit distutils-r1 pypi
+
+DESCRIPTION="sip extension module for PyQt5"
+HOMEPAGE="https://www.riverbankcomputing.com/software/sip/"
+
+LICENSE="|| ( GPL-2 GPL-3 SIP )"
+SLOT="0/$(ver_cut 1)"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc ~ppc64 ~riscv ~x86"