summaryrefslogtreecommitdiff
path: root/dev-python/PyQt6-sip/PyQt6-sip-13.4.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/PyQt6-sip/PyQt6-sip-13.4.0.ebuild')
-rw-r--r--dev-python/PyQt6-sip/PyQt6-sip-13.4.0.ebuild19
1 files changed, 19 insertions, 0 deletions
diff --git a/dev-python/PyQt6-sip/PyQt6-sip-13.4.0.ebuild b/dev-python/PyQt6-sip/PyQt6-sip-13.4.0.ebuild
new file mode 100644
index 000000000000..fca26761e4a1
--- /dev/null
+++ b/dev-python/PyQt6-sip/PyQt6-sip-13.4.0.ebuild
@@ -0,0 +1,19 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+inherit distutils-r1
+
+MY_P="${P/-/_}"
+
+DESCRIPTION="sip module support for PyQt6"
+HOMEPAGE="https://www.riverbankcomputing.com/software/sip/"
+SRC_URI="mirror://pypi/${P::1}/${PN}/${MY_P}.tar.gz"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="|| ( GPL-2 GPL-3 SIP )"
+SLOT="0"
+KEYWORDS="~amd64"