summaryrefslogtreecommitdiff
path: root/dev-python/PyQt6/PyQt6-6.4.2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/PyQt6/PyQt6-6.4.2.ebuild')
-rw-r--r--dev-python/PyQt6/PyQt6-6.4.2.ebuild4
1 files changed, 3 insertions, 1 deletions
diff --git a/dev-python/PyQt6/PyQt6-6.4.2.ebuild b/dev-python/PyQt6/PyQt6-6.4.2.ebuild
index d1f60a1efb1b..4e892b399454 100644
--- a/dev-python/PyQt6/PyQt6-6.4.2.ebuild
+++ b/dev-python/PyQt6/PyQt6-6.4.2.ebuild
@@ -3,6 +3,7 @@
EAPI=8
+DISTUTILS_EXT=1
DISTUTILS_USE_PEP517=sip
PYPI_NO_NORMALIZE=1
PYTHON_COMPAT=( python3_{9..11} )
@@ -76,8 +77,9 @@ src_prepare() {
PATH=${T}/cxx:${PATH}
}
-src_configure() {
+python_configure_all() {
append-cxxflags -std=c++17 # for old gcc / clang that use <17 (bug #892331)
+ append-cxxflags ${CPPFLAGS} # respect CPPFLAGS
pyqt-use_enable() {
local state=$(usex ${1} --enable= --disable=)