summaryrefslogtreecommitdiff
path: root/dev-python/appdirs
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/appdirs')
-rw-r--r--dev-python/appdirs/Manifest1
-rw-r--r--dev-python/appdirs/appdirs-1.4.3-r1.ebuild35
2 files changed, 36 insertions, 0 deletions
diff --git a/dev-python/appdirs/Manifest b/dev-python/appdirs/Manifest
index 032951f9da13..3b965e944b79 100644
--- a/dev-python/appdirs/Manifest
+++ b/dev-python/appdirs/Manifest
@@ -1,4 +1,5 @@
AUX appdirs-1.4.3-distutils.patch 782 BLAKE2B fcb1553424c0d22f4b60702ed7f771897cbb6e3f39078169bd1afe24a5c5825d629a286e620f5692414cd3f2aab9c38ae5ee20c2a18baee540ca685cc40a385e SHA512 e23630772b76f1a339ee74354f74f5d25d7c07a16db2b5ce307dbfd33f665c187aef86d7b7ec9e92bd43a3d8363fb40686d2bf49c10baa3b2825c8835e149905
DIST appdirs-1.4.3.tar.gz 9641 BLAKE2B edd7f6372e25279f6ba0f36cda595649cab7e69430e22bfdfd1bb5aa8d566a4a2fbf24c281adf80ab3eafea93f0f4f79b396688134395c3e5565476f24db75df SHA512 787f551ef5af355bbc77ffb3059553fab77614cce466b4145e4b55fecb8553d329f8748865fd69005d13451a9b11229a65721095a122db83a8433a2661503dfc
+EBUILD appdirs-1.4.3-r1.ebuild 1178 BLAKE2B fa045167dbc08aaa61e573cea99a3327ecd513a76dc387b30a01dfbf582a0d03d85495704d9286d867e41608e78324a2d014573659841da968a7a195f94dc911 SHA512 97c93bc34d042bc745086e8f60035ce19cef8aa2e0633a56069069aac9a8ab086b55c131c16dbe37b4af8b3f4aee614a593ce8d415202038e793962e5a9b4938
EBUILD appdirs-1.4.3.ebuild 1172 BLAKE2B bf0a7e9a89704f98fc89686ae8b8c60a2a70fc9f5d8ba63d482f879cbb4ff91939a6946e3f94705ecb28b0363b6561e1103f031cfbd750165c3c59b5fff06e80 SHA512 4f5669802072fc9a53a9d8da894efc0de490d76fe5c5056334af10ed6cb9177c9c2161a8a41f02a3b8a8990f05c8115c5563870441ba53e70f1a93dc3fb736ec
MISC metadata.xml 742 BLAKE2B 4731940c3aa6e3e0616487d4600c77f31712455aa70eff1bb900ec121cb062e45e1551206b86a5716b49f6163612096cb5ab9e3cf693af2d1fedaac023de29e6 SHA512 c1e35e090d6e3af99b8879a8a553c89989b149617857696fccecb4ea0435979f547049db2cdb7c505b50c20dc9f081233990f6fc0ee05de8ee27c7629292244e
diff --git a/dev-python/appdirs/appdirs-1.4.3-r1.ebuild b/dev-python/appdirs/appdirs-1.4.3-r1.ebuild
new file mode 100644
index 000000000000..c39cc5139148
--- /dev/null
+++ b/dev-python/appdirs/appdirs-1.4.3-r1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_{5,6,7,8} pypy{,3} )
+
+inherit distutils-r1
+
+DESCRIPTION="Module for determining appropriate platform-specific dirs"
+HOMEPAGE="https://github.com/ActiveState/appdirs"
+SRC_URI="https://github.com/ActiveState/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+
+PATCHES=( "${FILESDIR}"/${PN}-1.4.3-distutils.patch )
+
+python_test() {
+ "${PYTHON}" test/test_api.py -v || die "Tests fail with ${EPYTHON}"
+}
+
+[[ ${PV} == 1.4.3 ]] || die "Please remove pkg_preinst from the ebuild"
+pkg_preinst() {
+ _remove_egg_info() {
+ local pyver="$("${PYTHON}" -c 'import sys; print(sys.version[:3])')"
+ local egginfo="${ROOT}$(python_get_sitedir)/${P}-py${pyver}.egg-info"
+ if [[ -d ${egginfo} ]]; then
+ einfo "Removing ${egginfo}"
+ rm -r "${egginfo}" || die
+ fi
+ }
+ python_foreach_impl _remove_egg_info
+}