summaryrefslogtreecommitdiff
path: root/dev-python/argcomplete
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/argcomplete')
-rw-r--r--dev-python/argcomplete/Manifest2
-rw-r--r--dev-python/argcomplete/argcomplete-3.5.1.ebuild43
2 files changed, 45 insertions, 0 deletions
diff --git a/dev-python/argcomplete/Manifest b/dev-python/argcomplete/Manifest
index 860a20e1655c..536d787bf3ec 100644
--- a/dev-python/argcomplete/Manifest
+++ b/dev-python/argcomplete/Manifest
@@ -1,4 +1,6 @@
AUX argcomplete-3.1.6-timeout.patch 945 BLAKE2B dcdfadbdef547d45013eee33d00166b98eb6621a55f5e399cc7d330541a95118aff4a1646a85a1351209f88ff0e74d66e2468ffcf3db7e91d44ef453cc9c73e9 SHA512 fc26fc219d88a74d49245a2d545cb8040fb773fc7a948847380d4d343f19650994771a948fce99311cab7b52b3e040cf3f58291a0ac50b4a4f262dbb28c1bf85
DIST argcomplete-3.5.0.tar.gz 82237 BLAKE2B 7a5acd6f1311ec153333363e207037634b6901cca1415bd68d8e009888fa8cdfdfc3a50189f14c5da4bddfa5c861bbc009cf0d34248ff168caaa6ebad6ad8a7d SHA512 89c305a97b0808301976a48f9c8cb914e7cc12e33540cebd1c6514bbed8017db27b2232e3526abb74fe4f152f23c211be5a48aeafd63bbfca2dcc42f92b4877e
+DIST argcomplete-3.5.1.tar.gz 82280 BLAKE2B be4467ffae1fb5f6e433e2f80c43e33cc455883c7e8962d2add7dabfb8d6415daa9fc67538c394d4582828faf5036ceaaf8b1e158457529574405aa72ce51d8d SHA512 478680a65f2786f9bca0fd598a3c0d938759f8aacaec5506a08875dcd73fb0e13f3446d6500c694bb1943ebb65fdfd1544a51364c8f79d44eb02eb06294af9cc
EBUILD argcomplete-3.5.0.ebuild 1040 BLAKE2B 4ad46c8d579fd498e9e1ad02ed518b57ca3e198608fdcc46440781184ca226ff0426336f53549095b6c1d168e0e3153c8407ea2d37d728ce6834574879c54137 SHA512 7073e7dd5c9e7d74614ede91ec0fffa9c4344c3a18d56a9fbf75de93baa082a9c44fb8fb4b2894db274c19ee306d0adaa931ab8cfab92166ba9e8e05e176a816
+EBUILD argcomplete-3.5.1.ebuild 1048 BLAKE2B 97041588915d4337db420afda7fdda563d8792d3f0d91c6ae82c8de9e3fcff52aca92c1fca93e0feb9227b4a352767f2504a6232cb0011cef58746e3b937e021 SHA512 45be898e369507578e305462ab1fa0e2b167ba63a7610e3a85a4a2191c71cbfb9a8dbfc3e70ef0773e8ca755cf5a2bc0e46a550bc42320a256099dc309206f4f
MISC metadata.xml 411 BLAKE2B 963cfdba9183fde9e97c534345164d26be569d841dcc6fd274601b18d5de2ae97fa837b0acfdc59616c5d19cc54ea368547ffd901f90239cdfb5ba08e8721607 SHA512 22db237979be34053ad7201f599d576a7756b71e6b75c40c2808d47f276cce6d3594ae46dcaec5aa5adab9e9e24e11d47bb9044a8b1a146163d66687965cf5b7
diff --git a/dev-python/argcomplete/argcomplete-3.5.1.ebuild b/dev-python/argcomplete/argcomplete-3.5.1.ebuild
new file mode 100644
index 000000000000..a88f7842d276
--- /dev/null
+++ b/dev-python/argcomplete/argcomplete-3.5.1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} pypy3 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Bash tab completion for argparse"
+HOMEPAGE="
+ https://github.com/kislyuk/argcomplete/
+ https://pypi.org/project/argcomplete/
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-macos"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+# pip is called as an external tool
+BDEPEND="
+ test? (
+ app-shells/fish
+ app-shells/tcsh
+ app-shells/zsh
+ dev-python/pexpect[${PYTHON_USEDEP}]
+ >=dev-python/pip-19
+ )
+"
+
+PATCHES=(
+ # increase test timeouts -- this is particularly necessary
+ # for entry point tests because they read metadata of all installed
+ # packages which can take real long on systems with lots of packages
+ "${FILESDIR}/argcomplete-3.1.6-timeout.patch"
+)
+
+python_test() {
+ "${EPYTHON}" test/test.py -v || die
+}