summaryrefslogtreecommitdiff
path: root/dev-python/asttokens
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/asttokens')
-rw-r--r--dev-python/asttokens/Manifest4
-rw-r--r--dev-python/asttokens/asttokens-2.4.1.ebuild52
-rw-r--r--dev-python/asttokens/asttokens-3.0.0.ebuild4
3 files changed, 3 insertions, 57 deletions
diff --git a/dev-python/asttokens/Manifest b/dev-python/asttokens/Manifest
index 74d01e3f0eb5..c9f487d48ec5 100644
--- a/dev-python/asttokens/Manifest
+++ b/dev-python/asttokens/Manifest
@@ -1,5 +1,3 @@
-DIST asttokens-2.4.1.gh.tar.gz 57358 BLAKE2B dff2bdbbb62ed0c99f620284e4ad4abe418c315356caee26988ed7722a9aec77be4fe79b877e350cf632e076cd7c421f6ec824e7ffdda1d6684b03fffb15e7b2 SHA512 62263e50e14953e98236cdcbd75121ff5f6a3dc949170412a97f17af9b2572415373971d2286c4821b03249404b5a4c53ef5c7f1ec37aa9e2bf4a743d16de1da
DIST asttokens-3.0.0.gh.tar.gz 56937 BLAKE2B 38b3c9271ba57c032f552cb6dedd2cd2ef2eb6294b2f5e2fde4821260b73453495576b6641fa9450bd86f08ed4a296e010a5ce5f0f3502cbeb27857e1792802f SHA512 9d0f78ee90758d52fd15ee2f1940ddc14e8fc0d15e83fb01e731c6b79e328510f6c588c7856935aed99017b98f1daa99ee25802964990d59f63c62a0a5646804
-EBUILD asttokens-2.4.1.ebuild 1076 BLAKE2B c54d670acb8d84086b99ce6c95ffd0a5cf1528cd869bb95f829257e3e15789d609b6c6dee49f1ed800ee1b546c9fba747a895fa08805eb2d81e41cc2190d6d7c SHA512 0ac98688d360442b5e19f6bb789de39e4abc56a99067f167620f19b9fd456b3d6f0a1bdb865ee428c473bb1b4244ba1c7bc1147674af80a51e688e3919beedf8
-EBUILD asttokens-3.0.0.ebuild 793 BLAKE2B 3666af5e215057b9dd8b82d9ff225e8b07a379d2813203615f255e1fe358f813f0dbbef5041a5630e8d2b52c572bc9c0f3a80e3dc915d3c40eb8ec21fe05c373 SHA512 a259de1ff7ef9a0aa59b9f275eb1aa35b42d3560cf6c392c75dd7db379e1ff82e366ac03b0a8a3542094241f30b423574ff4676b08a49bc36b1acf3531f7dde4
+EBUILD asttokens-3.0.0.ebuild 792 BLAKE2B 078ec69904a1273e72e1da33311a361f65e08f4d426ae8514eaaf54e317d1c6624e65975092494bb5557163e422d36ad88ecfc41ed3630479e6e43ca26343745 SHA512 c44ebc78d6872c607b76c3351c1fd5964bedf9b20f177d0f714169b42a7c868073ede110a13dfabee3f414ab677925aae0686bbd9d5526df79ae8ab9a9874591
MISC metadata.xml 374 BLAKE2B a66534fe071a1c8185eb8047241e979b1da80abf0527c50f08cb36cb2b876ac691185b3094e4b91a3c38320aeb4ed45a9ab8758513115bfd4d91cffa5f5c5830 SHA512 efa821c8b432187cc3386d382fcbf0c9ed95dce1309e2fef14c57032718e7409f6703806dc139cd85dd13d1a2722e93eeb742db427f88d923da1481fb8be9817
diff --git a/dev-python/asttokens/asttokens-2.4.1.ebuild b/dev-python/asttokens/asttokens-2.4.1.ebuild
deleted file mode 100644
index 32f02bb81aa8..000000000000
--- a/dev-python/asttokens/asttokens-2.4.1.ebuild
+++ /dev/null
@@ -1,52 +0,0 @@
-# Copyright 2020-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( pypy3 python3_{10..13} )
-
-inherit distutils-r1
-
-DESCRIPTION="Annotate Python AST trees with source text and token information"
-HOMEPAGE="
- https://github.com/gristlabs/asttokens/
- https://pypi.org/project/asttokens/
-"
-SRC_URI="
- https://github.com/gristlabs/asttokens/archive/v${PV}.tar.gz
- -> ${P}.gh.tar.gz
-"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~loong ppc ppc64 ~riscv ~s390 sparc x86 ~arm64-macos ~x64-macos"
-
-RDEPEND="
- dev-python/six[${PYTHON_USEDEP}]
-"
-BDEPEND="
- dev-python/setuptools-scm[${PYTHON_USEDEP}]
- test? (
- dev-python/astroid[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-
-export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}
-
-python_test() {
- local EPYTEST_DESELECT=()
-
- case ${EPYTHON} in
- pypy3)
- EPYTEST_DESELECT+=(
- # already skipped in git
- tests/test_tokenless.py::TestFstringPositionsWork::test_fstring_positions_work
- )
- ;;
- esac
-
- epytest
-}
diff --git a/dev-python/asttokens/asttokens-3.0.0.ebuild b/dev-python/asttokens/asttokens-3.0.0.ebuild
index 035310192e6e..0284f00e0daf 100644
--- a/dev-python/asttokens/asttokens-3.0.0.ebuild
+++ b/dev-python/asttokens/asttokens-3.0.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 2020-2024 Gentoo Authors
+# Copyright 2020-2025 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -20,7 +20,7 @@ SRC_URI="
LICENSE="Apache-2.0"
SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 ~hppa ~loong ppc ppc64 ~riscv ~s390 sparc x86 ~arm64-macos ~x64-macos"
+KEYWORDS="~alpha amd64 arm arm64 hppa ~loong ppc ppc64 ~riscv ~s390 sparc x86 ~arm64-macos ~x64-macos"
BDEPEND="
dev-python/setuptools-scm[${PYTHON_USEDEP}]