summaryrefslogtreecommitdiff
path: root/dev-python/async-lru
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/async-lru')
-rw-r--r--dev-python/async-lru/Manifest2
-rw-r--r--dev-python/async-lru/async-lru-2.0.4.ebuild40
2 files changed, 42 insertions, 0 deletions
diff --git a/dev-python/async-lru/Manifest b/dev-python/async-lru/Manifest
index 03308d6b9c95..67b5170cc9d0 100644
--- a/dev-python/async-lru/Manifest
+++ b/dev-python/async-lru/Manifest
@@ -1,3 +1,5 @@
DIST async-lru-2.0.3.gh.tar.gz 12592 BLAKE2B 3b434ebcb5f4db754ca93dae3e597490b07ce6d84d573529343a540b77fc9116f329f641fb97639dce6903384e52433dc48aabb7927266e8bcc18ce9fbaa85ac SHA512 8a3685bccb09ae268a713b3796f1f945bc9f9beff14530eb997722c6a0546bb39860492eadc1a46fca6ed549352e20cd9983396127ee9edfbd50657b5e5dd58f
+DIST async-lru-2.0.4.gh.tar.gz 13084 BLAKE2B dc3316e63783f36a446fc0d3565e018340787822b4a2663b9759d8bf5222277526b9a1285a34c3d84ccd245f75c6a53d9a693cc13c2b101bcb4bc97fa31835bf SHA512 aed4a043bfb323c1fc01f93def11fe597141778bd8437bd90189e2b6da26b0bb412fa72fb0d12a40b771571f3cb5f06fed8302379aec2e8e0318eab179b64912
EBUILD async-lru-2.0.3.ebuild 867 BLAKE2B 5c334601970cc71b69d3c2fc9d1d8697de2d896bfac899d6c3bf33310b8163e104f50847355b6b88049857606cc5e043ab4a39fbb082183a6dcef2a3e6ca9d5c SHA512 c9d9c40026c39ec208dba5deb8f4cdb915fee9fb487292946b1686366ed6f557cbf52d29a6564f1f28c2191c05f3a39116d1994b51a4877919c310d4437b8184
+EBUILD async-lru-2.0.4.ebuild 727 BLAKE2B a300d7dc1335ffb793a800e19e0cbd5abcc66547c20851ec50e8b38ee12e18fe67c67d477db9b75d938e4cbc9ea7dcd4ae5f18c2e37dc8ea335ea19a321870df SHA512 c0bfddd08bae1e9e88e7b052e661dc733d88436c36ab3d7f947ffc138ea78ee20fb9df533f08d017cb43258580a816a92aef9d7d49273dbdb6e9acf07d5168c8
MISC metadata.xml 373 BLAKE2B bb8b67d9df0a86ac3a7d834e79bbc8a907d467e567f353b29427c9a36b11cc79eaa4d1b6f8cef9a43e632f7d333af72dcc1bc579922a1aabfc47cdffc7bd922a SHA512 c6c089b381a5c572b6ecc2907f2e90ee2f581516ac66a6f901d32990db5c8086eefcc97f80a90c9b83504934489c3440cac86ebbc0cbd76801510fba1a9f0ed3
diff --git a/dev-python/async-lru/async-lru-2.0.4.ebuild b/dev-python/async-lru/async-lru-2.0.4.ebuild
new file mode 100644
index 000000000000..0e1f63516ebd
--- /dev/null
+++ b/dev-python/async-lru/async-lru-2.0.4.ebuild
@@ -0,0 +1,40 @@
+# Copyright 2021-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Simple lru_cache for asyncio"
+HOMEPAGE="
+ https://github.com/aio-libs/async-lru/
+ https://pypi.org/project/async-lru/
+"
+SRC_URI="
+ https://github.com/aio-libs/async-lru/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ $(python_gen_cond_dep '
+ >=dev-python/typing-extensions-4.0.0[${PYTHON_USEDEP}]
+ ' 3.10)
+"
+BDEPEND="
+ test? (
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ epytest -o addopts=
+}