summaryrefslogtreecommitdiff
path: root/dev-python/async_timeout/async_timeout-1.2.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/async_timeout/async_timeout-1.2.1.ebuild')
-rw-r--r--dev-python/async_timeout/async_timeout-1.2.1.ebuild32
1 files changed, 0 insertions, 32 deletions
diff --git a/dev-python/async_timeout/async_timeout-1.2.1.ebuild b/dev-python/async_timeout/async_timeout-1.2.1.ebuild
deleted file mode 100644
index c0504b87b044..000000000000
--- a/dev-python/async_timeout/async_timeout-1.2.1.ebuild
+++ /dev/null
@@ -1,32 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-PYTHON_COMPAT=( python3_6 )
-
-inherit distutils-r1
-
-MY_P=${PN/_/-}-${PV}
-DESCRIPTION="Timeout context manager for asyncio programs"
-HOMEPAGE="https://github.com/aio-libs/async-timeout"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${MY_P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="test"
-RESTRICT="!test? ( test )"
-S=${WORKDIR}/${MY_P}
-
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
- dev-python/setuptools_scm[${PYTHON_USEDEP}]
- test? ( dev-python/pytest-aiohttp[${PYTHON_USEDEP}] )"
-
-python_prepare_all() {
- sed -i "s:, 'pytest-runner'::" -i setup.py || die
- distutils-r1_python_prepare_all
-}
-
-python_test() {
- py.test -v || die "Tests fail with ${EPYTHON}"
-}