summaryrefslogtreecommitdiff
path: root/dev-python/attrs/attrs-19.1.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/attrs/attrs-19.1.0.ebuild')
-rw-r--r--dev-python/attrs/attrs-19.1.0.ebuild37
1 files changed, 0 insertions, 37 deletions
diff --git a/dev-python/attrs/attrs-19.1.0.ebuild b/dev-python/attrs/attrs-19.1.0.ebuild
deleted file mode 100644
index cb1c61df86aa..000000000000
--- a/dev-python/attrs/attrs-19.1.0.ebuild
+++ /dev/null
@@ -1,37 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python2_7 python3_{6,7} pypy3 )
-
-inherit distutils-r1
-
-DESCRIPTION="Attributes without boilerplate"
-HOMEPAGE="
- https://github.com/hynek/attrs
- https://attrs.readthedocs.org/
- https://pypi.org/project/attrs/"
-SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
- dev-python/zope-interface[${PYTHON_USEDEP}]"
-
-DEPEND="
- ${RDEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]
- test? (
- $(python_gen_impl_dep sqlite)
- >=dev-python/hypothesis-3.6.0[${PYTHON_USEDEP}]
- dev-python/pytest[${PYTHON_USEDEP}]
- )"
-
-python_test() {
- py.test -v || die "tests failed with ${EPYTHON}"
-}