summaryrefslogtreecommitdiff
path: root/dev-python/audioread/audioread-2.1.9.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/audioread/audioread-2.1.9.ebuild')
-rw-r--r--dev-python/audioread/audioread-2.1.9.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/dev-python/audioread/audioread-2.1.9.ebuild b/dev-python/audioread/audioread-2.1.9.ebuild
new file mode 100644
index 000000000000..c14c97ad2fe9
--- /dev/null
+++ b/dev-python/audioread/audioread-2.1.9.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7,8,9} )
+inherit distutils-r1
+
+DESCRIPTION="Wrapper for audio file decoding using FFmpeg or GStreamer"
+HOMEPAGE="https://pypi.org/project/audioread/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="ffmpeg gstreamer +mad"
+# Enabled mad by default as it's the lighest dep to ease testing
+REQUIRED_USE="
+ ${PYTHON_REQUIRED_USE}
+ test? ( || ( ffmpeg gstreamer mad ) )
+"
+
+RDEPEND="
+ ffmpeg? ( media-video/ffmpeg )
+ gstreamer? (
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ media-libs/gstreamer:1.0
+ media-plugins/gst-plugins-meta:1.0
+ )
+ mad? ( dev-python/pymad )
+"
+
+python_prepare_all() {
+ distutils-r1_python_prepare_all
+ sed -e "/'pytest-runner'/d" -i setup.py || die
+}
+
+distutils_enable_tests pytest