summaryrefslogtreecommitdiff
path: root/dev-python/authres/authres-0.800.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/authres/authres-0.800.ebuild')
-rw-r--r--dev-python/authres/authres-0.800.ebuild21
1 files changed, 21 insertions, 0 deletions
diff --git a/dev-python/authres/authres-0.800.ebuild b/dev-python/authres/authres-0.800.ebuild
new file mode 100644
index 000000000000..1e4d080bd77a
--- /dev/null
+++ b/dev-python/authres/authres-0.800.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="Authentication Results Header Module"
+HOMEPAGE="https://launchpad.net/authentication-results-python https://pypi.org/project/authres/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+KEYWORDS="amd64 x86"
+SLOT="0"
+IUSE=""
+
+python_test() {
+ "${PYTHON}" -c "import sys, ${PN}, doctest; f, t = doctest.testfile('${PN}/tests'); \
+ sys.exit(bool(f))" || die "Tests fail with ${EPYTHON}"
+}