summaryrefslogtreecommitdiff
path: root/dev-python/authres/authres-1.2.0-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/authres/authres-1.2.0-r1.ebuild')
-rw-r--r--dev-python/authres/authres-1.2.0-r1.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-python/authres/authres-1.2.0-r1.ebuild b/dev-python/authres/authres-1.2.0-r1.ebuild
new file mode 100644
index 000000000000..274f78a74a92
--- /dev/null
+++ b/dev-python/authres/authres-1.2.0-r1.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Parse and generate Authentication-Results headers"
+HOMEPAGE="
+ https://launchpad.net/authentication-results-python/
+ https://pypi.org/project/authres/
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+SLOT="0"
+
+python_test() {
+ "${EPYTHON}" -m doctest -v authres/tests ||
+ die "Tests fail with ${EPYTHON}"
+}