summaryrefslogtreecommitdiff
path: root/dev-python/beagle/beagle-0.3.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/beagle/beagle-0.3.0.ebuild')
-rw-r--r--dev-python/beagle/beagle-0.3.0.ebuild17
1 files changed, 10 insertions, 7 deletions
diff --git a/dev-python/beagle/beagle-0.3.0.ebuild b/dev-python/beagle/beagle-0.3.0.ebuild
index cb43007e4195..08451f904513 100644
--- a/dev-python/beagle/beagle-0.3.0.ebuild
+++ b/dev-python/beagle/beagle-0.3.0.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python3_7 python3_8 )
-DISTUTILS_USE_SETUPTOOLS=rdepend
+
+PYTHON_COMPAT=( python3_{8..10} )
inherit distutils-r1
DESCRIPTION="Command line client for Hound, the code search tool."
@@ -14,9 +14,12 @@ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
LICENSE="Apache-2.0"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE=""
-DEPEND=">=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]"
-RDEPEND=">=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]
+# setuptools is needed as rdepend, https://github.com/beaglecli/beagle/pull/14
+RDEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ >=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]
>=dev-python/cliff-2.11.0[${PYTHON_USEDEP}]
- >=dev-python/requests-2.18.4[${PYTHON_USEDEP}]"
+ >=dev-python/requests-2.18.4[${PYTHON_USEDEP}]
+"
+BDEPEND=">=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]"