summaryrefslogtreecommitdiff
path: root/dev-python/beautifulsoup4/beautifulsoup4-4.9.3.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/beautifulsoup4/beautifulsoup4-4.9.3.ebuild')
-rw-r--r--dev-python/beautifulsoup4/beautifulsoup4-4.9.3.ebuild32
1 files changed, 0 insertions, 32 deletions
diff --git a/dev-python/beautifulsoup4/beautifulsoup4-4.9.3.ebuild b/dev-python/beautifulsoup4/beautifulsoup4-4.9.3.ebuild
deleted file mode 100644
index c9b54e80fbf0..000000000000
--- a/dev-python/beautifulsoup4/beautifulsoup4-4.9.3.ebuild
+++ /dev/null
@@ -1,32 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{8..10} pypy3 )
-
-inherit distutils-r1
-
-DESCRIPTION="Pythonic idioms for iterating, searching, and modifying an HTML/XML parse tree"
-HOMEPAGE="https://www.crummy.com/software/BeautifulSoup/bs4/"
-SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~x64-macos"
-
-RDEPEND="
- dev-python/soupsieve[${PYTHON_USEDEP}]
- dev-python/html5lib[${PYTHON_USEDEP}]
- dev-python/lxml[${PYTHON_USEDEP}]
-"
-BDEPEND="
- <dev-python/setuptools-58[${PYTHON_USEDEP}]
-"
-
-distutils_enable_tests nose
-distutils_enable_sphinx doc/source
-
-python_test() {
- nosetests --verbose -w "${BUILD_DIR}"/lib || die "Tests fail with ${EPYTHON}"
-}