summaryrefslogtreecommitdiff
path: root/dev-python/beautifulsoup
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/beautifulsoup')
-rw-r--r--dev-python/beautifulsoup/Manifest2
-rw-r--r--dev-python/beautifulsoup/beautifulsoup-4.9.2.ebuild33
2 files changed, 35 insertions, 0 deletions
diff --git a/dev-python/beautifulsoup/Manifest b/dev-python/beautifulsoup/Manifest
index ce53e6d16685..0299fed4cda4 100644
--- a/dev-python/beautifulsoup/Manifest
+++ b/dev-python/beautifulsoup/Manifest
@@ -1,3 +1,5 @@
DIST beautifulsoup4-4.9.1.tar.gz 374759 BLAKE2B 43f5dc296bd0c4967036fcb70889f988c0dfc9d8713f8bbab423c9089e87960323392458b3abb9b2332acff286efbbb308a5c77058462c15f8dfe9056f0304c3 SHA512 a1fe9cbfe8616d2ff25cc836769ff02d51ed86b06ca9a37366867b145440b7f64b866346600ed74820f0407c8e70eaac3d58700766a99b5ff7433cb736a57b3c
+DIST beautifulsoup4-4.9.2.tar.gz 375880 BLAKE2B 99137530e3b95aa4dde80b64dd42f0614c6429aca421208eab98764f7929c30a725e9df3625afa4a2c2e8bd4be56144cb9077e8e260741b6b306cfa696e6a076 SHA512 3bac5d57404e0be1e77a1bd560750e831c8636fc5f9b3c05b375c0cf44d6846ed73127a2a7d1d8ca657c21ec33854b8194f76b62820fb627d80a5906229a7454
EBUILD beautifulsoup-4.9.1.ebuild 865 BLAKE2B 56ad3bad060f06f8c8c5a423756737103788c45f0989e8ec3b6b73d3a5e3d2f9cdc8d45e488a518ea018fa24b04cff0ac670a1c25cd81a8cfed7845b6cbfea5e SHA512 4d7262aefafc557a8f5a82312043aa2128cff129032fba20a17b25363e2047cebd6c73423c16375a0690ad829aaa60fee13a0fba83022e00f2244e469e850028
+EBUILD beautifulsoup-4.9.2.ebuild 849 BLAKE2B 6d2b22bff7e16eac5f5e4fbabbd280d42d10fa671ea3f4b85384c9689bfcd8e0d4a46d6bd84644ac0023cd06cd9af2a79e12c24c764b248f01b7edf8fc5d61dc SHA512 3e8c20c173aba4009c59be54b2cd62ea748e6a8ed325e042bf951e5b6bcb3c4d06c45e877e5ebbda5226d42a57372b32b9f1bc20a68555369c87ac8afc916703
MISC metadata.xml 744 BLAKE2B 93987e4adb8dc5dea9b897940cae80d431b29d693bd1fea9d242de75174b1fd86afaecc6a5fb5e4ad06576caa559a918d09da28d253147f2683703d911435f76 SHA512 f56ab7ff03d21187e38f292b24396eccfd53622c84f5f489bd1e515393dbf85b75bbdfe26a6875352b16dcbf16f89cd9a051dfe44dbca8786efecd7db914f789
diff --git a/dev-python/beautifulsoup/beautifulsoup-4.9.2.ebuild b/dev-python/beautifulsoup/beautifulsoup-4.9.2.ebuild
new file mode 100644
index 000000000000..8c2e9be5885e
--- /dev/null
+++ b/dev-python/beautifulsoup/beautifulsoup-4.9.2.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6..9} pypy3 )
+
+inherit distutils-r1
+
+MY_PN="${PN}4"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Pythonic idioms for iterating, searching, and modifying an HTML/XML parse tree"
+HOMEPAGE="https://www.crummy.com/software/BeautifulSoup/bs4/"
+SRC_URI="mirror://pypi/${MY_P:0:1}/${MY_PN}/${MY_P}.tar.gz"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="MIT"
+SLOT="4"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86"
+
+RDEPEND="
+ dev-python/soupsieve[${PYTHON_USEDEP}]
+ dev-python/html5lib[${PYTHON_USEDEP}]
+ dev-python/lxml[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests nose
+distutils_enable_sphinx doc/source
+
+python_test() {
+ nosetests --verbose -w "${BUILD_DIR}"/lib || die "Tests fail with ${EPYTHON}"
+}