summaryrefslogtreecommitdiff
path: root/dev-python/boltons
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/boltons')
-rw-r--r--dev-python/boltons/Manifest2
-rw-r--r--dev-python/boltons/boltons-24.1.0.ebuild34
2 files changed, 36 insertions, 0 deletions
diff --git a/dev-python/boltons/Manifest b/dev-python/boltons/Manifest
index 1b69a8c93ae1..be4f4bdd6a6a 100644
--- a/dev-python/boltons/Manifest
+++ b/dev-python/boltons/Manifest
@@ -1,3 +1,5 @@
DIST boltons-24.0.0.tar.gz 239550 BLAKE2B e7001b3aa04834f1d234ff7ce996cebd32293189cdf000c8b36719d24b51ab24098c58ad3df58e938a58f319a575b8a0f2f09cec423d33b876103b89ad7d85bb SHA512 afc7f9d495d91e38219378f9f4f287918d6e5b19feb1299c5f504cab1d4a3e0a5fb9fa1c073d46f941c86a18086af5be3a44506d986b010b2595da0c2b908b48
+DIST boltons-24.1.0.tar.gz 240916 BLAKE2B 65f3b3e3c495bcd168badd776e0e04da2339c52fddbaa4ba4ccce6ddc1f6143ab224fa6d89cc4f9a5632fcf91b2e7beac31f92e9587004282b24e177670e9bef SHA512 9f61fb9c9e0a56abc75c61c56bc47ac8ab219d0abd14f700ca609b61f25df392c1b5be3a2bfecd1a2b2c73a50e407c6f90f0460341dfa23d8dfdf8ad530974af
EBUILD boltons-24.0.0.ebuild 956 BLAKE2B 1e0b371ae2fe9ae553c921036a138b87ed17b9de2bce2730f2443776a60410715b273b12d012c3acd37f274c021f70458e84acbd18ca9cdd3c75067b08732c31 SHA512 9a9e748220b328e2eb7e27edc36746d58de95608eb30fcf15dfe3695b53b99d5c4e3342d3c944fb89271cc24fbdcd4b74628227b0aa8bc97e4c7866e2adb59f9
+EBUILD boltons-24.1.0.ebuild 963 BLAKE2B 9cce263501c31c28a4ed5789bcf12bd2fa15334855a8ceb53fa75b8f0170923da81fdf8554e1e55b132eb3ca9a5825e55176ca0d2c8e45f41a61d17d675814a9 SHA512 ee3e09166c33d42ae48a7c8aa14917432539cfc3c0a198addf96a7f12dbc53aa1b7a4f2071336359c894540ba78545a22870f7e44647dcd815c18af72a2d5a7f
MISC metadata.xml 395 BLAKE2B 6ed304f1dced75dfd795b9fe582ec669bf1c8ba5fefeb9e753b11aa20de8fc0966fc9a8a0ed40e460dd23a67ef0e5721a8dae27b3d799a4be629537bb18f54c9 SHA512 fb73041a95df230153dc686e21a88d91bb06367ae8c22a20777c4a0f13202cbaf59396f4ed2630265d331d6461a6da85f57ba62cc432c4d9105b8404753b383b
diff --git a/dev-python/boltons/boltons-24.1.0.ebuild b/dev-python/boltons/boltons-24.1.0.ebuild
new file mode 100644
index 000000000000..27be1e660905
--- /dev/null
+++ b/dev-python/boltons/boltons-24.1.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 2021-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{10..13} )
+inherit distutils-r1 pypi
+
+DESCRIPTION="Pure-python utilities in the same spirit as the standard library"
+HOMEPAGE="https://boltons.readthedocs.io/"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+distutils_enable_tests pytest
+
+DOCS=( CHANGELOG.md README.md TODO.rst )
+
+src_test() {
+ # tests break with pytest-qt, django, and likely more
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+
+ local EPYTEST_DESELECT=(
+ # fails with 3.13, but ignore for now given causes no
+ # issues for the only revdep (maturin's tests)
+ # https://github.com/mahmoud/boltons/issues/365
+ tests/test_funcutils_fb_py3.py::test_update_wrapper_partial\[boltons.funcutils\]
+ tests/test_tbutils.py::test_exception_info
+ )
+
+ distutils-r1_src_test
+}