summaryrefslogtreecommitdiff
path: root/dev-python/boto
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/boto')
-rw-r--r--dev-python/boto/Manifest5
-rw-r--r--dev-python/boto/boto-2.41.0.ebuild55
-rw-r--r--dev-python/boto/boto-2.48.0.ebuild55
-rw-r--r--dev-python/boto/metadata.xml13
4 files changed, 0 insertions, 128 deletions
diff --git a/dev-python/boto/Manifest b/dev-python/boto/Manifest
deleted file mode 100644
index 3c4aceb005dc..000000000000
--- a/dev-python/boto/Manifest
+++ /dev/null
@@ -1,5 +0,0 @@
-DIST boto-2.41.0.tar.gz 1440323 BLAKE2B 9d72fcd09cbf57d22dc45d42699af8cecef6f2c8e4009c9d70b54a9b84e23801ecbb5f7bc484692ca93ae302793b4d2f511c1209bcd33d0703a39b809bda1e00 SHA512 ffb503e8f7ec84ec973e109ae9524e1db2ef5f34d9424c380eed9a85871f07f8c9c798ca358fefd772ff45a72226bb02eebbbf6ab2d56b2442c41ede736f6f5e
-DIST boto-2.48.0.tar.gz 1461372 BLAKE2B 0069ddc6def7d8698471bd66a5d8d4b62d49f49138036b3ae6a9655e7b7432af5449f2812e83f2012be2f01e93a61d9608157c9fd4ea0a52f8801e31877a78a7 SHA512 ce8e302b059ef31e81078ef21999b96b8770d2ef0c70358624c8cc6a79b1a43a78e1c206cbcba50eafb9c964c4eda5b9b0b127ea9523dcf7438453b4b2293f9f
-EBUILD boto-2.41.0.ebuild 1407 BLAKE2B 7f0b2235803a64a37933e506d91cb2f8608c257d27a312fc408550dc2414ffa3f1c1ab097278de4a5f72190aa8f806f25e4b081a887399467c67ae222400bfed SHA512 240390b93cab9c10e1a67e2c7e8fdbb19857c80d3702e25867d8338e23cc6246628394ec17008428b2ee705adc6152b748e32ca5136b9332232b9850b1a0aebf
-EBUILD boto-2.48.0.ebuild 1419 BLAKE2B 25a5ec90dcab7e7d13149e4ab3efff60c259d04e8c680faa8bc1e7adf4a95071f900b24fa1b5b8e850f7c16be9d20ac5a06862d25a833dbe3df3c3eb59c78855 SHA512 e88045ae9cbd39d30d0250e095d78e920d241156de4b63275614d1ec93262fb1ef26735b47e2810c3e16eea1fe693d78788ac9d7e1db845b23ef260ede6f5106
-MISC metadata.xml 419 BLAKE2B c6c19e4ba3ecc5a36b535267b75cdf3afb7317e577e8f0899d43a334632633d771b5e5216517537616cc99c7766a852d2b4c5b132e174f8481d86649253e0897 SHA512 ee5587224538b14f67c30eda60c161e4c07c801c4b4edb24bcb0350e17c4d655c4d9a6907ebe5913d7689e1b6078ef25f47b4fe0a7c655cfa8d5ea775b4d0329
diff --git a/dev-python/boto/boto-2.41.0.ebuild b/dev-python/boto/boto-2.41.0.ebuild
deleted file mode 100644
index c3b00d0dbf3f..000000000000
--- a/dev-python/boto/boto-2.41.0.ebuild
+++ /dev/null
@@ -1,55 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
-
-inherit distutils-r1
-
-DESCRIPTION="Amazon Web Services API"
-HOMEPAGE="https://github.com/boto/boto https://pypi.org/project/boto/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="amd64 arm ppc sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
-IUSE="doc test"
-
-REQUIRED_USE="doc? ( || ( $(python_gen_useflags 'python2*') ) )"
-
-DEPEND="
- dev-python/setuptools[${PYTHON_USEDEP}]
- test? ( dev-python/nose[${PYTHON_USEDEP}] )
- doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )"
-
-# requires Amazon Web Services keys to pass some tests
-RESTRICT="test"
-
-pkg_setup() {
- use doc && DISTUTILS_ALL_SUBPHASE_IMPLS=( 'python2*' )
-}
-
-python_test() {
- "${PYTHON}" tests/test.py -v || die "Tests fail with ${EPYTHON}"
-}
-
-python_prepare_all() {
- # Prevent un-needed d'loading
- sed -e "s/, 'sphinx.ext.intersphinx'//" -i docs/source/conf.py || die
- distutils-r1_python_prepare_all
-}
-
-python_compile_all() {
- if use doc; then
- # Appease the doc build and supply a file for _static
- # the usual emake -C docs doesn't work under this authorship
- cd docs && mkdir source/_static || die
- emake html
- fi
-}
-
-python_install_all() {
- use doc && local HTML_DOCS=( docs/build/html/. )
- distutils-r1_python_install_all
-}
diff --git a/dev-python/boto/boto-2.48.0.ebuild b/dev-python/boto/boto-2.48.0.ebuild
deleted file mode 100644
index 08a852151e64..000000000000
--- a/dev-python/boto/boto-2.48.0.ebuild
+++ /dev/null
@@ -1,55 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
-
-inherit distutils-r1
-
-DESCRIPTION="Amazon Web Services API"
-HOMEPAGE="https://github.com/boto/boto https://pypi.org/project/boto/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
-IUSE="doc test"
-
-REQUIRED_USE="doc? ( || ( $(python_gen_useflags 'python2*') ) )"
-
-DEPEND="
- dev-python/setuptools[${PYTHON_USEDEP}]
- test? ( dev-python/nose[${PYTHON_USEDEP}] )
- doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )"
-
-# requires Amazon Web Services keys to pass some tests
-RESTRICT="test"
-
-pkg_setup() {
- use doc && DISTUTILS_ALL_SUBPHASE_IMPLS=( 'python2*' )
-}
-
-python_test() {
- "${PYTHON}" tests/test.py -v || die "Tests fail with ${EPYTHON}"
-}
-
-python_prepare_all() {
- # Prevent un-needed d'loading
- sed -e "s/, 'sphinx.ext.intersphinx'//" -i docs/source/conf.py || die
- distutils-r1_python_prepare_all
-}
-
-python_compile_all() {
- if use doc; then
- # Appease the doc build and supply a file for _static
- # the usual emake -C docs doesn't work under this authorship
- cd docs && mkdir source/_static || die
- emake html
- fi
-}
-
-python_install_all() {
- use doc && local HTML_DOCS=( docs/build/html/. )
- distutils-r1_python_install_all
-}
diff --git a/dev-python/boto/metadata.xml b/dev-python/boto/metadata.xml
deleted file mode 100644
index e630c4673422..000000000000
--- a/dev-python/boto/metadata.xml
+++ /dev/null
@@ -1,13 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="project">
- <email>python@gentoo.org</email>
- <name>Python</name>
- </maintainer>
- <upstream>
- <remote-id type="google-code">boto</remote-id>
- <remote-id type="pypi">boto</remote-id>
- <remote-id type="github">boto/boto</remote-id>
- </upstream>
-</pkgmetadata>