summaryrefslogtreecommitdiff
path: root/dev-python/castellan/castellan-0.4.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/castellan/castellan-0.4.0.ebuild')
-rw-r--r--dev-python/castellan/castellan-0.4.0.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-python/castellan/castellan-0.4.0.ebuild b/dev-python/castellan/castellan-0.4.0.ebuild
new file mode 100644
index 000000000000..aa1c79087c71
--- /dev/null
+++ b/dev-python/castellan/castellan-0.4.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 python3_4 python3_5 )
+
+inherit distutils-r1
+
+DESCRIPTION="Generic Key Manager interface for OpenStack"
+HOMEPAGE="https://pypi.python.org/pypi/castellan"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="amd64 ~arm64 x86"
+IUSE=""
+
+CDEPEND=" >=dev-python/pbr-1.6[${PYTHON_USEDEP}]"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ ${CDEPEND}"
+RDEPEND="
+ ${CDEPEND}
+ >=dev-python/Babel-1.3
+ >=dev-python/cryptography-1.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-config-3.7.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-context-0.2.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-log-1.14.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-policy-0.5.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-serialization-1.10.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-utils-3.5.0[${PYTHON_USEDEP}]"