summaryrefslogtreecommitdiff
path: root/dev-python/cattrs/cattrs-23.1.2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/cattrs/cattrs-23.1.2.ebuild')
-rw-r--r--dev-python/cattrs/cattrs-23.1.2.ebuild76
1 files changed, 0 insertions, 76 deletions
diff --git a/dev-python/cattrs/cattrs-23.1.2.ebuild b/dev-python/cattrs/cattrs-23.1.2.ebuild
deleted file mode 100644
index 30d1c61d53bb..000000000000
--- a/dev-python/cattrs/cattrs-23.1.2.ebuild
+++ /dev/null
@@ -1,76 +0,0 @@
-# Copyright 2022-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=poetry
-PYTHON_COMPAT=( python3_{10..12} )
-
-inherit distutils-r1 multiprocessing
-
-DESCRIPTION="Composable complex class support for attrs and dataclasses"
-HOMEPAGE="
- https://pypi.org/project/cattrs/
- https://github.com/python-attrs/cattrs/
-"
-SRC_URI="
- https://github.com/python-attrs/cattrs/archive/v${PV}.tar.gz
- -> ${P}.gh.tar.gz
-"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="amd64 arm arm64 ~hppa ~loong ~ppc ppc64 ~riscv ~s390 ~sparc x86"
-IUSE="test-rust"
-
-RDEPEND="
- >=dev-python/attrs-20.1.0[${PYTHON_USEDEP}]
- $(python_gen_cond_dep '
- dev-python/exceptiongroup[${PYTHON_USEDEP}]
- >=dev-python/typing-extensions-4.1.0[${PYTHON_USEDEP}]
- ' 3.{9..10})
-"
-BDEPEND="
- test? (
- >=dev-python/cbor2-5.4.6[${PYTHON_USEDEP}]
- >=dev-python/hypothesis-6.54.5[${PYTHON_USEDEP}]
- >=dev-python/immutables-0.18[${PYTHON_USEDEP}]
- >=dev-python/msgpack-1.0.2[${PYTHON_USEDEP}]
- >=dev-python/pymongo-4.2.0[${PYTHON_USEDEP}]
- dev-python/pytest-xdist[${PYTHON_USEDEP}]
- >=dev-python/pyyaml-6.0[${PYTHON_USEDEP}]
- >=dev-python/tomlkit-0.11.4[${PYTHON_USEDEP}]
- >=dev-python/ujson-5.4.0[${PYTHON_USEDEP}]
- test-rust? (
- >=dev-python/orjson-3.5.2[${PYTHON_USEDEP}]
- )
- )
-"
-
-distutils_enable_tests pytest
-
-src_prepare() {
- local PATCHES=(
- # https://github.com/python-attrs/cattrs/pull/415
- "${FILESDIR}/${P}-32bit-time_t.patch"
- )
-
- sed -e 's:--benchmark.*::' \
- -e '/addopts/d' \
- -i pyproject.toml || die
- distutils-r1_src_prepare
-}
-
-python_test() {
- local EPYTEST_DESELECT=()
- if ! has_version "dev-python/orjson[${PYTHON_USEDEP}]"; then
- EPYTEST_DESELECT+=(
- tests/test_preconf.py::test_orjson
- tests/test_preconf.py::test_orjson_converter
- tests/test_preconf.py::test_orjson_converter_unstruct_collection_overrides
- )
- fi
-
- local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
- epytest -p xdist -n "$(makeopts_jobs)" tests
-}