summaryrefslogtreecommitdiff
path: root/dev-python/cfn-lint/cfn-lint-0.83.2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/cfn-lint/cfn-lint-0.83.2.ebuild')
-rw-r--r--dev-python/cfn-lint/cfn-lint-0.83.2.ebuild9
1 files changed, 2 insertions, 7 deletions
diff --git a/dev-python/cfn-lint/cfn-lint-0.83.2.ebuild b/dev-python/cfn-lint/cfn-lint-0.83.2.ebuild
index 787cd17c5e65..cb9d73f6e9d8 100644
--- a/dev-python/cfn-lint/cfn-lint-0.83.2.ebuild
+++ b/dev-python/cfn-lint/cfn-lint-0.83.2.ebuild
@@ -7,7 +7,7 @@ DISTUTILS_USE_PEP517=setuptools
PYPI_NO_NORMALIZE=1
PYTHON_COMPAT=( python3_{10..11} )
-inherit distutils-r1 multiprocessing pypi
+inherit distutils-r1 pypi
DESCRIPTION="CloudFormation Linter"
HOMEPAGE="
@@ -33,11 +33,6 @@ RDEPEND="
>=dev-python/sarif-om-1.0.4[${PYTHON_USEDEP}]
>=dev-python/sympy-1.0.0[${PYTHON_USEDEP}]
"
-BDEPEND="
- test? (
- dev-python/pytest-xdist[${PYTHON_USEDEP}]
- )
-"
distutils_enable_tests pytest
@@ -66,5 +61,5 @@ python_test() {
# from tox.ini
local -x AWS_DEFAULT_REGION=us-east-1
local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
- epytest -p xdist -n "$(makeopts_jobs)" --dist=worksteal
+ epytest
}