summaryrefslogtreecommitdiff
path: root/dev-python/cftime/cftime-1.6.2-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/cftime/cftime-1.6.2-r1.ebuild')
-rw-r--r--dev-python/cftime/cftime-1.6.2-r1.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/dev-python/cftime/cftime-1.6.2-r1.ebuild b/dev-python/cftime/cftime-1.6.2-r1.ebuild
new file mode 100644
index 000000000000..c7709831ca42
--- /dev/null
+++ b/dev-python/cftime/cftime-1.6.2-r1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 2020-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_EXT=1
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Time-handling functionality from netcdf4-python"
+HOMEPAGE="
+ https://github.com/Unidata/cftime/
+ https://pypi.org/project/cftime/
+"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~riscv ~x86"
+
+DEPEND="
+ >=dev-python/numpy-1.13.4[${PYTHON_USEDEP}]
+"
+RDEPEND="
+ ${DEPEND}
+"
+BDEPEND="
+ >=dev-python/cython-0.29.20[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ local PATCHES=(
+ "${FILESDIR}/${P}-cython-3.patch"
+ )
+
+ # remove pytest-cov dep
+ sed -e "/--cov/d" -i setup.cfg || die
+
+ distutils-r1_python_prepare_all
+}