summaryrefslogtreecommitdiff
path: root/dev-python/cherrypy/cherrypy-18.8.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/cherrypy/cherrypy-18.8.0.ebuild')
-rw-r--r--dev-python/cherrypy/cherrypy-18.8.0.ebuild7
1 files changed, 6 insertions, 1 deletions
diff --git a/dev-python/cherrypy/cherrypy-18.8.0.ebuild b/dev-python/cherrypy/cherrypy-18.8.0.ebuild
index bc25b0613a09..f1daafcdd228 100644
--- a/dev-python/cherrypy/cherrypy-18.8.0.ebuild
+++ b/dev-python/cherrypy/cherrypy-18.8.0.ebuild
@@ -6,7 +6,7 @@ EAPI=8
DISTUTILS_USE_PEP517=setuptools
PYPI_NO_NORMALIZE=1
PYPI_PN="CherryPy"
-PYTHON_COMPAT=( python3_{9..11} pypy3 )
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
inherit distutils-r1 pypi
@@ -47,6 +47,11 @@ BDEPEND="
distutils_enable_tests pytest
python_prepare_all() {
+ local PATCHES=(
+ # https://github.com/cherrypy/cherrypy/pull/1959
+ "${FILESDIR}/${P}-py312.patch"
+ )
+
sed -i -e '/cov/d' pytest.ini || die
# upstream has been using xfail to mark flaky tests, then added
# xfail_strict... not a good idea