summaryrefslogtreecommitdiff
path: root/dev-python/clang-python/clang-python-15.0.1.9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/clang-python/clang-python-15.0.1.9999.ebuild')
-rw-r--r--dev-python/clang-python/clang-python-15.0.1.9999.ebuild6
1 files changed, 6 insertions, 0 deletions
diff --git a/dev-python/clang-python/clang-python-15.0.1.9999.ebuild b/dev-python/clang-python/clang-python-15.0.1.9999.ebuild
index 2891edc42793..f0290ca4c7b1 100644
--- a/dev-python/clang-python/clang-python-15.0.1.9999.ebuild
+++ b/dev-python/clang-python/clang-python-15.0.1.9999.ebuild
@@ -29,12 +29,18 @@ RDEPEND="
"
BDEPEND="
${PYTHON_DEPS}
+ test? (
+ sys-devel/clang:${PV%%.*}
+ )
"
LLVM_COMPONENTS=( clang/bindings/python )
llvm.org_set_globals
python_test() {
+ # tests rely on results from a specific clang version, so override
+ # the search path
+ local -x CLANG_LIBRARY_PATH=${BROOT}/usr/lib/llvm/${PV%%.*}/$(get_libdir)
"${EPYTHON}" -m unittest discover -v || die "Tests fail with ${EPYTHON}"
}