summaryrefslogtreecommitdiff
path: root/dev-python/cleo/cleo-2.1.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/cleo/cleo-2.1.0.ebuild')
-rw-r--r--dev-python/cleo/cleo-2.1.0.ebuild12
1 files changed, 11 insertions, 1 deletions
diff --git a/dev-python/cleo/cleo-2.1.0.ebuild b/dev-python/cleo/cleo-2.1.0.ebuild
index eeb083c81bf9..d8fa9f6dea6a 100644
--- a/dev-python/cleo/cleo-2.1.0.ebuild
+++ b/dev-python/cleo/cleo-2.1.0.ebuild
@@ -4,7 +4,7 @@
EAPI=8
DISTUTILS_USE_PEP517=poetry
-PYTHON_COMPAT=( python3_{10..12} )
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
inherit distutils-r1
@@ -41,6 +41,16 @@ src_prepare() {
}
python_test() {
+ local EPYTEST_DESELECT=()
+
+ case ${EPYTHON} in
+ pypy3)
+ EPYTEST_DESELECT+=(
+ tests/ui/test_exception_trace.py::test_render_debug_better_error_message_recursion_error
+ )
+ ;;
+ esac
+
local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
local -x PYTEST_PLUGINS=pytest_mock
epytest