summaryrefslogtreecommitdiff
path: root/dev-python/click-log/click-log-0.3.2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/click-log/click-log-0.3.2.ebuild')
-rw-r--r--dev-python/click-log/click-log-0.3.2.ebuild12
1 files changed, 4 insertions, 8 deletions
diff --git a/dev-python/click-log/click-log-0.3.2.ebuild b/dev-python/click-log/click-log-0.3.2.ebuild
index ceb7bb78774e..7d9bc6d73ff9 100644
--- a/dev-python/click-log/click-log-0.3.2.ebuild
+++ b/dev-python/click-log/click-log-0.3.2.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=6
-PYTHON_COMPAT=( python{2_7,3_5,3_6} )
+PYTHON_COMPAT=( python{2_7,3_5,3_6,3_7} )
inherit distutils-r1
@@ -12,15 +12,11 @@ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
LICENSE="MIT"
SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="test"
+KEYWORDS="~amd64 ~arm64 ~x86"
RDEPEND="dev-python/click[${PYTHON_USEDEP}]"
-DEPEND="${RDEPEND}
- test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
+DEPEND="${RDEPEND}"
DOCS=( README.rst )
-python_test() {
- py.test -v || die "Tests fail with ${EPYTHON}"
-}
+distutils_enable_tests pytest