summaryrefslogtreecommitdiff
path: root/dev-python/cliff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/cliff')
-rw-r--r--dev-python/cliff/Manifest2
-rw-r--r--dev-python/cliff/cliff-3.5.0.ebuild41
2 files changed, 43 insertions, 0 deletions
diff --git a/dev-python/cliff/Manifest b/dev-python/cliff/Manifest
index aff05e8f7f4a..b2c6f23c84bd 100644
--- a/dev-python/cliff/Manifest
+++ b/dev-python/cliff/Manifest
@@ -1,3 +1,5 @@
DIST cliff-3.4.0.tar.gz 78990 BLAKE2B d7d8209e2fe24614cde6d3e113eb0dbbba981addef045fe318143e71f9a240188c0fb74e831d868b31b6dafb4289f7beabfbb5fe1dade1df196f670c53a55549 SHA512 d625588f4eed0aeee549b4a21e604f1cb886b8c10a12df7c546a5292223ec5bf9067352b4d326d5710673dab56eec47e2fb46c9c5d5df6e9fbf026d030bcde1c
+DIST cliff-3.5.0.tar.gz 82997 BLAKE2B f169770a0a956e6091e56eccda8d10906bee09bdb03b474f3b17837b3eda858f3afd21beae1d6945bcdabfa89fc1555d13d70ddd0454a10fe05bfb63c8de75e7 SHA512 215f22e5dd2c4c17bd0f19866189b6b247377a7d5bddeb4a07b7536af7545bd0440b5fb0a98474fc018e3b12f6695f60028c012f3e7eeb6498b20f2923939d08
EBUILD cliff-3.4.0.ebuild 1203 BLAKE2B 4bac1690e15c736c6ca79ed940a0459811e05e6264949aae242807d266c988fc09e2c0fcd69c8606ce5c54cc260b7b50a8c40cd15234d56f70ccc6f367a902e5 SHA512 26f04001fba369a2805f3e4c33ffc69953a8e1d921e88a1c63c861cebbcd1dc42204e629a3bb34b6afeeae04fc72e196192ff6b944b387299ece48562c29e9f7
+EBUILD cliff-3.5.0.ebuild 1209 BLAKE2B 06c8d877c1fe0181403667f586e99328dd67c1c2ba7fa34c06546e24e81a244182855e9b23e73183099fedef7dffe5a09c5b9e1b7e2af736a877387078a038bb SHA512 bb3d0f6698272acdfeee15d40a4daa5416ab631e327d1f14d94ae5bceef0e14033af5c4635aedde8bff2de13a56cc88ada596f4ce580a62f15fc87328f2a8efa
MISC metadata.xml 734 BLAKE2B cdfc9f839d8dd599e27c78314ca5688d94dc52b3128d0aca7c6ff11d8b7f5f9de9d2d43f6690543d8e44b8483899d0cc21ef7273dbbdbeca0b498b2a593279a9 SHA512 6103b640d65a93bbd2cd9cf6ca6ae42a12a0fbfcdc26dd164494b777bc976d14d7e0bd94372b84ed30f7eab3e1acb54787671d90f165cbf6b0b160770cdbcfff
diff --git a/dev-python/cliff/cliff-3.5.0.ebuild b/dev-python/cliff/cliff-3.5.0.ebuild
new file mode 100644
index 000000000000..5e6f9629a908
--- /dev/null
+++ b/dev-python/cliff/cliff-3.5.0.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6..9} )
+# TODO: revert to rdepend once this is merged
+# https://github.com/openstack/cliff/pull/3
+DISTUTILS_USE_SETUPTOOLS=manual
+
+inherit distutils-r1
+
+DESCRIPTION="Command Line Interface Formulation Framework"
+HOMEPAGE="https://github.com/openstack/cliff"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm64 ~hppa ~ia64 ~mips ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ >=dev-python/cmd2-0.8.0[${PYTHON_USEDEP}]
+ <dev-python/prettytable-0.8[${PYTHON_USEDEP}]
+ >=dev-python/pyparsing-2.1.0[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ >=dev-python/six-1.10.0[${PYTHON_USEDEP}]
+ >=dev-python/stevedore-2.0.1[${PYTHON_USEDEP}]
+ >=dev-python/pyyaml-3.12.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ >=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]
+ !~dev-python/pbr-2.1.0
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/sphinx[${PYTHON_USEDEP}]
+ >=dev-python/testtools-2.2.0[${PYTHON_USEDEP}]
+ >=dev-python/testscenarios-0.4[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests unittest