summaryrefslogtreecommitdiff
path: root/dev-python/comm
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/comm')
-rw-r--r--dev-python/comm/Manifest2
-rw-r--r--dev-python/comm/comm-0.1.4.ebuild30
2 files changed, 32 insertions, 0 deletions
diff --git a/dev-python/comm/Manifest b/dev-python/comm/Manifest
index b4d99cf8a866..1ac2d324a736 100644
--- a/dev-python/comm/Manifest
+++ b/dev-python/comm/Manifest
@@ -1,3 +1,5 @@
DIST comm-0.1.3.gh.tar.gz 7345 BLAKE2B 2cbe791d226316800a37886d8c68b05ac9d9860bc92e1d95f8b428038a090d9867abfa0860262a9daba3ccd4fd607743df4f8d7fb2c13bf63456d17aa5f69092 SHA512 05696e8b58245ecb02ef0b4e23e904bae8288a6dad6530a9e15587bb0922a8d57f32803a5a34eb8f79eb620f679bb77350842bc441c0ab665a7ca9f7196106c4
+DIST comm-0.1.4.gh.tar.gz 7504 BLAKE2B e020809077f5366737453fc8e56dc5b7751effc99f4766fddf1eecfa9a560aad7f17b56987ba072c5412a77761b3b978cfab34cbf62bd29e58160075e20d203d SHA512 5a3993b17d249a8c1be20ed8647ac0621517d500b4b933c78c05386d23d6d660175679a779a3a20818703f5c962c9a351916715a4f244b989ff2f6568382146a
EBUILD comm-0.1.3.ebuild 685 BLAKE2B 498fa4baa3f09a4a4e40978b0038d9fa1e771f947a9e8889e12f66fbf6d08239482c1576f3480039f13b44fac6b57f423019c1c0604261b463d236072cd93e73 SHA512 7707bf81f7a0a9c2f025dfed75963007f23441caa132ed8d42313702b5bd4624f8f43f3cad68566e6d7d0374d83c26a3888180682430b398b64e28b4670c1ac4
+EBUILD comm-0.1.4.ebuild 691 BLAKE2B ec286fb6e0769eaf8d75c768e6d7b0429cb2389a0cf36f60eb110770a09052a44668edde388d89a56034df5ec8f15208d02cdc1079ca058f2bd5f7d2b9086c38 SHA512 308e9d776fe8d5b2b097a81e3d18eb563df39d2f88e67dad7d2556caae25b0a0425e35e4f07ee19ca0b172ef1ecc7f4ccf132f8194e3f1d8efb1145df9b596f6
MISC metadata.xml 384 BLAKE2B c122aaf6c2b9e6776b19efa2549030f0267c1d553f92862c5ecf21926f30a9c3cd7564434a573cca6fdbb85485eb49213b4d95100e8de2a29ced9c9c1fa81153 SHA512 b06853ad3cb1775ad70e44c48bca74bcf85c11715291974e7e3ee496344256fc57b91920812f19809e7cf14f6a7f7938531934d6a12740baec0dd984d5d48632
diff --git a/dev-python/comm/comm-0.1.4.ebuild b/dev-python/comm/comm-0.1.4.ebuild
new file mode 100644
index 000000000000..d7f404401a5b
--- /dev/null
+++ b/dev-python/comm/comm-0.1.4.ebuild
@@ -0,0 +1,30 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="Jupyter Python Comm implementation, for usage in ipykernel, xeus-python"
+HOMEPAGE="
+ https://github.com/ipython/comm/
+ https://pypi.org/project/comm/
+"
+# no tests in sdist, as of 0.1.3
+SRC_URI="
+ https://github.com/ipython/comm/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ >=dev-python/traitlets-4[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest