summaryrefslogtreecommitdiff
path: root/dev-python/couchdb-python
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/couchdb-python')
-rw-r--r--dev-python/couchdb-python/Manifest5
-rw-r--r--dev-python/couchdb-python/couchdb-python-1.1.ebuild43
-rw-r--r--dev-python/couchdb-python/metadata.xml16
3 files changed, 64 insertions, 0 deletions
diff --git a/dev-python/couchdb-python/Manifest b/dev-python/couchdb-python/Manifest
new file mode 100644
index 000000000000..1b4ce02ca99e
--- /dev/null
+++ b/dev-python/couchdb-python/Manifest
@@ -0,0 +1,5 @@
+DIST CouchDB-1.1.tar.gz 60839 SHA256 9503ea413956c33b5e2af248235afb5e0f011f33f816a32e872f8ff9b0a0e710 SHA512 f68a0bb04f74cf91ae7d190eedec2a9c24c03dd0ef333c27cca7ef7abc95d3d355f78d653d68371a0d27dcc9a8d69f5886627f0eb0c6af49b632becf6bd0668f WHIRLPOOL 44f51ab1a2f05edd8cf2219ce6fb108d99264f4dd952cf71ae89030fe97c2adf54350ae7352271200be2861e4f1e33a199aa072cebd0e16d9f489b8657470f59
+EBUILD couchdb-python-1.1.ebuild 957 SHA256 21d990cd0e5df731b7101503b5bec8bb1b07c845296f7bd989e58dc58002f4ef SHA512 2b3aeada200b3db93c0da0b35fb92d92649da1198d0262d95d70902268c9ca5dc7335a5440a67bf36931e771a68bb6e8d224fb7b3aa83e8f69fcd1e734f91b28 WHIRLPOOL c05232360cc97f0a16d86cf0a9cfab8fca5614ef77194369807a9c3b8556e3438942ffd8a3e749c633230304dbf86b3b8ea81e4b0de66ebba25e1c5d1f1d21cb
+MISC ChangeLog 3889 SHA256 9db3215019117b77449821a6b2f4ae102a9065410799ae09a3ffc4a523458b3f SHA512 e1beb022d3ea6710a934bbfc6278ffede91c9ba08322d9b30ec30a72e1ce453bf456ae7956c187e21b4c17c0ced5d8d1208b0a1c19c5f35126dfb848b613f58f WHIRLPOOL 30f41dd933709df33633cee3e1fe970333e075f64209d6fc0f851edc07586f49cd80ca87ff54957758f1525cdae508b7fe64759920e128edb2bbf5c6e46cd28a
+MISC ChangeLog-2015 5187 SHA256 8a86de75fc77684b67d5ed5257aac384ab85cafdce6a5620ab83e75a8a01c3f9 SHA512 8ecbdd36ed39981eea330d332aab8c6452e6795d1ee8ea7288dfeecbdf82f5ff62895f15dab3da7cdf7bff46fda0dffa3c5e128be11e8244f1e40839d93af351 WHIRLPOOL eba64b66deef11d3238722622a23a46d5fc0b7f14c616e37a8cbc64a133d6bde840550c4e8ad4c2d34d7cdfc39832e5ec9c89573b4444e4e868e922eb43fa25c
+MISC metadata.xml 492 SHA256 1183c959b5c18be387479fb15e1292d95ee0645151a3322d21aa77cdd6863d0e SHA512 69b7bd6ace846417beb252df5372a01726879e839a14c8586deb33a6ff53a2279b088f822cd30d86af58197d9202526eac40d9394f74dbc4093b1dc23277b10f WHIRLPOOL 68b0016bd099f27edbb968fcc3dc34fb2b1d8fb22d0d7070b0a6b1fd478c909a873d5508a72e749dc7a6d4928a2f319ac1c24b11668656e3e84dc4f03a89fd0c
diff --git a/dev-python/couchdb-python/couchdb-python-1.1.ebuild b/dev-python/couchdb-python/couchdb-python-1.1.ebuild
new file mode 100644
index 000000000000..ad0a9c93f976
--- /dev/null
+++ b/dev-python/couchdb-python/couchdb-python-1.1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy )
+
+inherit distutils-r1
+
+MY_PN="CouchDB"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Python library for working with CouchDB"
+HOMEPAGE="https://github.com/djc/couchdb-python https://pypi.python.org/pypi/CouchDB"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 ~arm64 x86"
+IUSE="doc"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )"
+
+S=${WORKDIR}/${MY_P}
+
+# Tests require connectivity to a couchdb server.
+# Re-enable when the ebuild is capable of starting a local couchdb
+# instance.
+RESTRICT=test
+
+python_compile_all() {
+ use doc && esetup.py build_sphinx
+}
+
+python_test() {
+ esetup.py test
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( doc/build/html/. )
+ distutils-r1_python_install_all
+}
diff --git a/dev-python/couchdb-python/metadata.xml b/dev-python/couchdb-python/metadata.xml
new file mode 100644
index 000000000000..20b3c9795df2
--- /dev/null
+++ b/dev-python/couchdb-python/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>djc@gentoo.org</email>
+ <name>Dirkjan Ochtman</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">CouchDB</remote-id>
+ <remote-id type="github">djc/couchdb-python</remote-id>
+ </upstream>
+</pkgmetadata>