summaryrefslogtreecommitdiff
path: root/dev-python/cryptography/cryptography-2.0.2-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/cryptography/cryptography-2.0.2-r1.ebuild')
-rw-r--r--dev-python/cryptography/cryptography-2.0.2-r1.ebuild51
1 files changed, 0 insertions, 51 deletions
diff --git a/dev-python/cryptography/cryptography-2.0.2-r1.ebuild b/dev-python/cryptography/cryptography-2.0.2-r1.ebuild
deleted file mode 100644
index c69917dc3a69..000000000000
--- a/dev-python/cryptography/cryptography-2.0.2-r1.ebuild
+++ /dev/null
@@ -1,51 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy{,3} )
-PYTHON_REQ_USE="threads(+)"
-
-inherit distutils-r1 flag-o-matic
-
-DESCRIPTION="Library providing cryptographic recipes and primitives"
-HOMEPAGE="https://github.com/pyca/cryptography/ https://pypi.org/project/cryptography/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="|| ( Apache-2.0 BSD )"
-SLOT="0"
-KEYWORDS="amd64 arm arm64 hppa ia64 ~mips ppc ppc64 x86"
-IUSE="libressl test"
-
-RDEPEND="
- !libressl? ( >=dev-libs/openssl-1.0.2:0=[-bindist(-)] )
- libressl? ( dev-libs/libressl:0= )
- $(python_gen_cond_dep '>=dev-python/cffi-1.7:=[${PYTHON_USEDEP}]' 'python*')
- $(python_gen_cond_dep 'dev-python/enum34[${PYTHON_USEDEP}]' python2_7 pypy{,3})
- >=dev-python/idna-2.1[${PYTHON_USEDEP}]
- >=dev-python/asn1crypto-0.21.0[${PYTHON_USEDEP}]
- dev-python/setuptools[${PYTHON_USEDEP}]
- >=dev-python/six-1.4.1[${PYTHON_USEDEP}]
- virtual/python-ipaddress[${PYTHON_USEDEP}]
- "
-DEPEND="${RDEPEND}
- >=dev-python/setuptools-1.0[${PYTHON_USEDEP}]
- test? (
- ~dev-python/cryptography-vectors-${PV}[${PYTHON_USEDEP}]
- dev-python/hypothesis[${PYTHON_USEDEP}]
- dev-python/iso8601[${PYTHON_USEDEP}]
- dev-python/pretend[${PYTHON_USEDEP}]
- dev-python/pyasn1-modules[${PYTHON_USEDEP}]
- >=dev-python/pytest-2.9.0[${PYTHON_USEDEP}]
- dev-python/pytz[${PYTHON_USEDEP}]
- )"
-
-DOCS=( AUTHORS.rst CONTRIBUTING.rst README.rst )
-
-python_configure_all() {
- append-cflags $(test-flags-CC -pthread)
-}
-
-python_test() {
- py.test -v -v -x || die "Tests fail with ${EPYTHON}"
-}